View Full Version : cannot get to help, is there no pdf?

02-07-2009, 04:36 PM
I just installed 9.6 on OS X 10.5.6.

After activating, when I click on the Help -> Contents menu - it displays a window with NewTek at the top.

I see on the left 'Installed Help' and under that 'start here - table of contents'.

When I click on that I get an window that says 'Internet Connection Required'.

I'm connected and can view http and ftp thru the internet using Safari.

What does it want? Is there some setup where I need to tell it about the proxy server? Can't it just get that from my internet connections. As I can't get to 'help' - I have no way to tell.

BTW - isn't there a PDF of the manual?


02-07-2009, 04:52 PM
Hi !

Log on to your Register page and you'll have PDF manuals (Modeler, layout and surfacing) for download. there is SCREEN (smaller file) and Print (bug files) versions of them.


02-07-2009, 05:04 PM
Lewis - yes, I can see those now.

BTW - any idea why the on-line help doesn't work? If Safari works, it should work, I would think?

And several of the links take me to places on newTek site that don't exists. (like this link in my registration email:

Might discourage a new user evaluating the product a bit.


02-07-2009, 05:16 PM
I think Online help points to wrong link or something, i don't remember exactly but it's been mentioned before and it's been long time when i used it :) :).

And you are right about discouraging new users (NT should fix that). I hope you won't be discouraged and we will try to help you here if you need more assistance :). That's something LW community has - lot of sharing :).

Welcome to LightWave :).

02-07-2009, 05:29 PM
Lewis - I liked the forums and on-line videos so much, I ordered it last week, without even installing it.

Ordered 3D Arsenal also, I sure hope it works with 9.6! (that is a good assumption, yes?)

Thanks for taking the time to respond!

02-07-2009, 05:43 PM
Good to hear you liked Videos :).

I'm not sure about 3D Arsenal 'coz i didn't use it but maybe someone will answer it soon, there is a lot of traffic on these forums so you sometime have better chance to get answer faster than searching into manuals :D.

02-08-2009, 05:22 AM
first of all, I assume you have downloaded the Mac Help files and have installed them correctly.
If you are working in a multi-user setup (as me) install everything from the admin account and start Modeler and Layout (to get rid of these annoying OSX "do you really want to start..." questions in a normal account). Therefore you should also start the help once from admin account.
(I can call up the help only from Modeler, not from Layout, so I usually start the LW Help from Finder).
Had also the problem with 10.5.6 asking for an internet connection to access the helpfiles.
There was a thread during OpenBeta phase in which I informed Chilton that I could fix this behavior (for me) by deleting a broken stylesheet link.
If you don't fear to manipulate html/css and have a text editor (like barebones free "textwrangler" or even textedit) you can delete this link and see if it helps for you too (it hasn't been fixed by newtek).
You find this link in "LW Application Folder > Shared Support > Help > Webhelp > introduction.html"
line 13: <LINK href="../../../test001/DefaultCSSFiles/C1H_Source_full.css" rel="stylesheet">
And yes, there are some links that should have been updated by newtek as they are pointing to non-existant webpages.
The whole help system should be modernized to meet todays conventions, but newtek cleverly put their time in developing LW and Core.
I'm okay with that ;-)

02-08-2009, 05:49 AM

Seriously, I remember fixing and thoroughly testing that CSS bug for the final RC of LightWave3D 9.6. I have no idea why it's still there. I'll go poke at it later today.

But again, event this shouldn't be necessary. It should properly link into the Mac OSX Help system when you run LightWave the first time after you install the help files. And if that's still not happening, I'm not sure why it would fail.


02-08-2009, 11:57 AM
Hi Chilton,

didn't even realize that this link is still there. After a clean new install of RC9.6 and help files on my Leopard MacPro I didn't run into this issue, so I thought it was fixed. I just realized it's still in after I read 3dWannabe's post, and thought that it could help him.
Btw. I never had any problems with it on my older Tiger-G5, so it could be a individual configuration issue.

I'm rather looking forward to some new Core reveals in the near future. :thumbsup:

02-08-2009, 12:06 PM
I had not installed the help files.

The email I received after registering didn't mention them, so you might want to re-work what that says (I did the 30 day trial, as I haven't received my copy yet).

Both of the main links in the registration confirmation were broken:

Tutorials: http://www.newtek.com/lightwave/lwtrial/tutorials.php
Content: http://www.newtek.com/lightwave/lwtrial/content.php

I'll get the help installed tonight, and see what trouble I get into, and try that 'fix' for the on-line help saying 'no internet connection'.

BTW - when you say install from an 'admin' account - instructions like that ( and how to do it) would be useful to have in the registration email.

All my other mac software asks me for user/pass - so I'm unfamiliar with exactly how to do that.


02-09-2009, 10:30 AM
Hello 3dWannabe,

for the help files:
it could be that everything works fine after install and additional fixes aren't needed.

I would recommend to download the new install guide written by Chuck Baker
( you can download from this post: http://www.newtek.com/forums/showthread.php?t=94245 ).
It offers a good overview which files go where and where you could install 3rd party plug-ins or save your own presets and so on.

And if you don't know them already, you should definitely have a look at these pages:

BTW - when you say install from an 'admin' account - instructions like that ( and how to do it) would be useful to have in the registration email.

(O.k. sorry, when I disturbed you).
This depends on whether you have set up your Mac with multiple user accounts and different privileges or not.
If you only have one user account on your machine, it is an Administrator account by default (so you can just install your software and you are fine).

If you have set up your Mac (for security reasons) with one Admin and one (or more) standard (administrated) accounts, you normally use the Admin account only for installation and maintainance, but are working within a so called standard / administrated account.
This is primarily OSX stuff and has nothing to do with LW in particular.
(When you install software (from an administrator account) you usually have to enter your administrator password for the installation.
After that, you can use the software normally.
If you have a multiple user set-up, you install within admin account, but you are working (usually) within a standard user account. In this case, under Leopard, you will get a annoying "do you want to open application xyz..." question with every application launch, if you didn't lauch that software at least once from within the admin account).

Hope, this clears up a bit.

02-26-2009, 02:20 PM
This whole discussion should not exist. If you are going to hotkey a function to go to a help page, then for god's sake, make it function correctly. Why do i need to research how to install a file that i am trying to access because I am DOING RESEARCH.

This fact frustrates me every time I run across it.

02-26-2009, 02:50 PM
rsfd -thanks for you patient answer. I always thought I was running as a non-admin, as it would ask for the password to install.

miquel - I understand where you are coming from, but I think that Newtek employees have only so many hours in the day.

They seem to be focusing on product development rather than the smaller issues that will affect new users.

I think, from reading about Core, that they may be moving to a subscription model. This is good, it means more money for NewTek, and hopefully more employees to pay attention to the finer details.

If you thought getting LW setup was fun, you should have tried 3dArsenal, where the installer crashed on my Mac Pro.

The bottom line is, they have great software, but we'll have to figure out a bunch of stuff for ourselves for a while, and some details that seem important to us (the pdf bookmarks which don't function on all platforms are pretty important to me to be able to learn LW, as there's no context sensitive help) just won't get addressed for a while.

This may be a bit shortsighted, as it takes up more tech support phone time, but - as long as the software's great, we'll hang in there!

02-26-2009, 03:18 PM
A quick work around if you have an old PC that is hooked to the internet is to load LW on it (registering it properly of course) and move your dongle to it to open lightwave and use that F1.

Once you get to the online help, it doesn't seem to require the dongle so you can move it back to your Mac.

Many thanks to the guy who started this thread. It saved me so much pain and suffering.

02-26-2009, 03:41 PM
If you are moving your dongle, there's an L shaped adapter at Fry's and other stores that will keep your dongle from sticking out like a sore thumb - with the possibility of getting broken off.