PDA

View Full Version : Lightwave 9.6 on the Mac...Problem loading old LW files



bugzilla
02-03-2009, 08:46 PM
I got a Mac at home recently and love it. I bought Unity to build iPhone games. To test it out, I downloaded a free Lightwave object of the Lunar Lander from Turboquid. I tried to open it in LW 9.6 on the Mac. It would not load. I started Blender and selected Import LWO. Blender loaded the Lightwave object fine.

So Blender can open native Lightwave files that Lightwave can't? Pathetic. Just pathetic.

evenflcw
02-03-2009, 08:49 PM
Did LW give any reason why it couldn't load it? Are you certain it was a native LWO? Perhaps it was exported from Blender in the first place...

EDIT: Lander by Shrox? Loaded fine on PC. I guess something really is (still) amiss on the Mac then.

Chilton
02-03-2009, 09:45 PM
Hi,

I assume you're referring to this one, by Shrox:
http://www.turbosquid.com/FullPreview/Index.cfm/ID/150483

The problem you'll have with this is that it was made on a PC, and with an earlier version of LightWave, before we had the Package Scene system we have in 9.6. Specifically, these files were made in 1991.

Yes, I know this is a headache. We tried to fix this going forward for 9.6, with the Package Scene system, but there isn't much we can do for these older files. Also, there appears to be a dependence on a DARKFRACTAL.TGA file that isn't in that set of files at all.

LightWave will try to help you figure out where the files should go, but if you spend a minute ahead of time cleaning up the platform differences, it will load instantly. What follows is a series of steps you can take to overcome the cobwebs. But if you don't feel like it, just follow the instructions that LightWave gives you, and you should be fine.

But if you're interested, here's how to clean up that stuff...

The LWO model files refer to several files that are not in the same directory they were when this file was created, and the file paths are in PC format, so you'll have to point LightWave at them, which it will ask you to do when it can't find them. The LWO format is a bitmap format, and going in and changing text strings isn't advised.

That DARKFRACTAL.TGA file is the main culprit.
1) First though, set your content directory to the ApolloFree folder. That will help both Modeler and Layout find some of the files. Do that in Layout by going to the Edit menu in LightWave's side vertical menus, and choosing Set Content Directory from the Edit menu.
2) In the Finder, double-click the DarkFractal.jpg file in Preview, do a Save As... and choose TGA. Then make an Images folder in the ApolloFree folder, and a REFLECTIONS folder in that, and put the DARKFRACTAL.TGA file in that.

3) Fix the scene file: Just open it in any text editor, and replace the references that look like this...

LoadObject C:\Models\1TurboSquid\ApolloFree\ApolloCommand.lwo

with something like this...

LoadObject ApolloCommand.lwo

4) Once you've done that, save the scene file back out

Once you've done these things, the scene and objects should load with no hassles.

Let me know if you have any other problems, and I'd be happy to help.

Also, I included a pic of one way you could set up the directory structure that will save you some headaches later on.

Thanks!
-Chilton