PDA

View Full Version : Need antialiasing for fiberfx when rendering through transparent objects



aSkeptic
01-31-2009, 08:30 AM
FiberFX looks rotten through a window

Sensei
01-31-2009, 09:37 AM
Rays from camera are handled by pixel-filter, that is why it's nicer, but when it hit some geometry and ray bounce, like transparent window, ray is handled by volumetric part. This is like you would use Volume Only mode..

aSkeptic
01-31-2009, 11:42 AM
So basically lightwave is broken?

Captain Obvious
01-31-2009, 12:40 PM
Surely FiberFX renders with anti-aliasing through refractions and reflections, if you actually have anti-aliasing turned on in the camera properties? It shows up in ray tracing as a volumetric effect, does it not? And they typically anti-alias as they should...

aSkeptic
01-31-2009, 12:45 PM
10 passes of antialiasing doesn't look much better than 5 passes. It looks great (even with no camera antialiasing), if there's nothing transparent in the way.

Sensei
01-31-2009, 12:51 PM
In such post you really should attach picture so we can see what is going on.. One picture, thousand words..

Sekhar
01-31-2009, 01:40 PM
Guys, I'm having an even more basic problem... Really hope it's me doing something wrong. If I block a FFX object with glass, there's no FFX behind the glass. What gives? 64 bit 9.6 on Vista.

aSkeptic
01-31-2009, 02:06 PM
Hi Sekhar,

If your glass has any reflectivity you need to enable the reflections button in the fiberfx panel (near the edit guide button). If that doesnt' help enable volume only. Took me 3 weeks to figure that out.

aSkeptic
01-31-2009, 02:18 PM
In such post you really should attach picture so we can see what is going on.. One picture, thousand words..

Well I've got a couple things going on now. So here's 6 thousand words:

So far this looks ok with 5 passes of anti aliasing
http://ohiovr.com/lightwave_bugs/hair_aliasing/5%20passes%20persective%20camera%20helmet%20on.jpg

But if I want to animate the helmet being put on I've got some trouble:
helmet off, no other changes:
http://ohiovr.com/lightwave_bugs/hair_aliasing/1%20pass%20no%20helmet.jpg

Things get a little denser on its own with the camera a bit further away:
http://ohiovr.com/lightwave_bugs/hair_aliasing/1%20pass%20no%20helmet%20distance.jpg

helmet on with no anti aliasing:
http://ohiovr.com/lightwave_bugs/hair_aliasing/1%20pass%20helmet%20on%20distance.jpg

Now with 10 passes the hair looks about the same as the ragged image before, 50 passes would look about the same but I'm not going to wait 30 hours to prove it:
http://ohiovr.com/lightwave_bugs/hair_aliasing/10%20passes%20no%20helmet%20far.jpg

This is one of the better test renders I've had (happy with) and would like to preserve this quality with the helmet on:
http://ohiovr.com/lightwave_bugs/hair_aliasing/test002.jpg

Sekhar
01-31-2009, 02:19 PM
The glass doesn't reflect, and I did try the volume only as well. :(

aSkeptic
01-31-2009, 02:23 PM
Hmm.. Sorry that didn't help. Could you try the reflections button anyway? I dunno worth a shot... I couldn't get my render working with out it on.

Sekhar
01-31-2009, 02:36 PM
Hmm.. Sorry that didn't help. Could you try the reflections button anyway? I dunno worth a shot... I couldn't get my render working with out it on.

Nope, that didn't work either. Anyway, looks like that's not (at least directly) related to your problem, so I'll post it separately so I don't hijack your thread. Thanks.

BTW, would you mind posting your scene so we can test it + I can compare it with what I have (you have glass too, but seem to get the render fine).

aSkeptic
01-31-2009, 02:41 PM
I'd actually be more comfortable testing your scene. I tried downloading your zip but it only contained the scene file. Could you post the scene and objects in a zip?

Sekhar
01-31-2009, 03:47 PM
I'd actually be more comfortable testing your scene. I tried downloading your zip but it only contained the scene file. Could you post the scene and objects in a zip?

Thanks, actually I got a response on my thread (http://www.newtek.com/forums/showthread.php?p=819258#post819258) - turns out you need to turn on both transparency and reflections together.

BTW, I'm seeing the difference inside/outside glass on my renders too. Monitor that thread too, you might get answers for your problem as well.

toby
01-31-2009, 04:32 PM
Tried the Volume only option and wow! Shows up behind glass, but it looks awful and takes 10 times longer! Render the glass separately and composite it, it's not worth the trouble until they make it work with transparency.

There must be a big FiberFX thread around here too, it might have some answers.