PDA

View Full Version : modo Won't Let Me Open .lwo Files with Model !



Carmel
01-14-2009, 04:12 PM
I'm working in Windows XP with Model 9.5. I can not get my system to open an .lwo file with Model. Believe me, I know how to assign an application to a file type. In fact, I know two different ways to do it. But no matter what I do, when I try to designate Model as the application to open .lwo files, modo takes its place. I can assign other applications, such as Deep Exploration, to open .lwos. That works fine. Just can't assign Lightwave to do it. Anyone else have this problem? Did you find a workaround? Hopefully I don't have to reinstall modo or anything drastic like that?

Thanks.

beverins
01-15-2009, 08:06 AM
It might have to do with a locked registry setting. Some viruscheckers or "system protectors" do that to prevent malware, viruses and trojans from making a hash of your file extensions.

Another thing to try is that it might have been ADDED to a list of acceptable programs. Try right clicking and then go to OPEN WITH... and you might find that the list has MODO and MODELER below it. What that means is that Modo is the Preferred application, but Windows understands that MODELER is the secondary choice.

biliousfrog
01-15-2009, 09:40 AM
I've got that too, I only tried the Modo demo but I can't get Lightwave to assign LWO's. I'm sure I read something about deleting the 'feedback.exe' and you'll be able to assign it ok but I can't remember who said it.

Carmel
01-15-2009, 11:11 AM
Another thing to try is that it might have been ADDED to a list of acceptable programs. Try right clicking and then go to OPEN WITH... and you might find that the list has MODO and MODELER below it. What that means is that Modo is the Preferred application, but Windows understands that MODELER is the secondary choice.

I can't even get Modeler to appear in the 'Open With' list, or the 'Choose Program' list that appears below it. It's like Windows XP doesn't recognize Modeler as an application on my system. For cases like these, XP offers a 'Browse' button which lets you navigate through your folders to find the application. So I do that, find 'modeler.exe', click on it, and it's ignored with no error message. The file still opens with modo or Deep Exploration (whichever I've previously designated).

Is it possible that Luxology does something to XP to make it ignore Newtek products?

beverins
01-15-2009, 12:14 PM
Seems to have an element of the problem - that trying to add modeler to the Open With won't work...

http://techrepublic.com.com/5208-11184-0.html?forumID=47&threadID=172890&messageID=1759550

Their fix is to reinstall, which is not really a solution LOL
I don't think it's modo because I have modo and LWO's open in both apps with Open With on my PC (though the default is LW).

One idea is to reinstall LW into the same folder. You won't lose license info because Newtek's installer leaves it alone (always smart to have a backup, it's only a txt file after all)

mattclary
01-15-2009, 01:12 PM
I can't even get Modeler to appear in the 'Open With' list, or the 'Choose Program' list that appears below it. It's like Windows XP doesn't recognize Modeler as an application on my system. For cases like these, XP offers a 'Browse' button which lets you navigate through your folders to find the application. So I do that, find 'modeler.exe', click on it, and it's ignored with no error message. The file still opens with modo or Deep Exploration (whichever I've previously designated).

Is it possible that Luxology does something to XP to make it ignore Newtek products?

You should have the option to "Browse" to find the program. Go find the executable for Modeler and select "Always use the selected program"

mattclary
01-15-2009, 01:19 PM
From My Computer, go to Tools > Options then the "File Types" tab. Select "Change". Find the .LWO file type, select "Browse" and find modeler.exe

Andyjaggy
01-15-2009, 01:27 PM
I've had this problem as well, and done exactly what Matt was saying to do and still had windows refuse to actually assign that program to the file type.

biliousfrog
01-15-2009, 03:25 PM
From My Computer, go to Tools > Options then the "File Types" tab. Select "Change". Find the .LWO file type, select "Browse" and find modeler.exe

That doesn't work, it refuses to select the exe...it's hard to explain but I can assure you that something blocks the ability to assign LWO's to modeler when Modo is installed

beverins
01-16-2009, 08:51 AM
it is definitely a registry key corruption. Try reinstalling Lightwave on top of itself into the same folder.

Or, edit yer Registry to get rid of the modo assignment or change it back to modeler.exe

http://windowsxp.mvps.org/OpenWith.htm

beverins
01-16-2009, 08:53 AM
You could also try this utility

http://windowsxp.mvps.org/fileextinfo.htm

beverins
01-16-2009, 08:56 AM
For example, it generated this for me
I have no idea why firefox is registered to open LWO :-D
--------------------
===============================================

[HKEY_CLASSES_ROOT\.LWO]
@="Newtek.Modeler"

[HKEY_CLASSES_ROOT\.LWO\OpenWithProgids]
"lwoFileHandler"=hex(0):


[HKEY_CLASSES_ROOT\Newtek.Modeler]
@="LightWave 3D"

[HKEY_CLASSES_ROOT\Newtek.Modeler\DefaultIcon]
@="C:\\NewTek\\LightWave 3D 9.6 Beta\\Programs\\modeler.exe,2"

[HKEY_CLASSES_ROOT\Newtek.Modeler\shell]

[HKEY_CLASSES_ROOT\Newtek.Modeler\shell\open]

[HKEY_CLASSES_ROOT\Newtek.Modeler\shell\open\comman d]
@="\"C:\\NewTek\\LightWave 3D 9.6 Beta\\modeler.exe\" %1"


[HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\FileExts\.LWO]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\FileExts\.LWO\OpenWithList]
"a"="lightwav.exe"
"MRUList"="acdgjibhf"
"b"="modo.exe"
"c"="modeler.exe"
"d"="firefox.exe"
"e"="3d-brush.exe"
"f"="maya.exe"
"g"="Photoshop.exe"
"h"="SketchUp.exe"
"i"="faogen.exe"
"j"="3d-coat.exe"

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\FileExts\.LWO\OpenWithProgids]
"modo.LWOFile"=hex(0):
"lwoFileHandler"=hex(0):
"Newtek.Modeler"=hex(0):
============================================