View Full Version : Bones do nothing

12-26-2008, 09:27 PM
It's been forever since I've used bones, and I've obviously forgotten something critical to getting them to work.

I have a simple subdivided object which I want to deform using bones. I tried to set them up in Layout, and it went fine until I tried to deform the object, and nothing happened. (Yes, I activated the bones.)

So I went back to Modeler and created Skelegons. I also created weight maps and assigned them to the various Skelegons. But after converting them to bones in Layout, I get the same result: set up keyframes for the bones, but they do NO deformation. (Yes, the bones are assigned to the proper object, and are within range to exercise great influence.)

I've checked the Bones panel, and everything "looks" right to me, so here I am, wondering what I am forgetting ...

Any help or sugestions would be greatly appreciated.

LW 8.5, Mac Pro w/ Quad core Intel Xeon.


12-26-2008, 09:34 PM
Best thing would be to pack scene+object and attach it here.
Faster than guessing :)

Making it supersimple.. If you just draw one bone in layout, activate it, and then rotate it. This works right?

Jim M
12-26-2008, 09:37 PM
Setup Tab / Enable Deform
+(Select all bones / Rest / Create Key for all)

12-26-2008, 09:59 PM
Well, I decided to do a far simpler object and scene, to both see if that worked, and to send it to you guys, and wouldn't ya know it, everything worked fine ... same exact procedure, this time with the expected results. So there's something strange with this particular object and/or scene ... but I can't share it cause of non-disclosure. Sigh.

I'll go in and make sure all aspects of the object are clean, etc.

Thanks for being there ... :-)

12-27-2008, 04:37 AM
Apparently bones don't work if you first move the deform object's pivot point in Layout. Doh!