View Full Version : BESM and raytraced shadows

02-24-2003, 05:38 PM
I am working on an animated short that makes heavy use of the BESM shader. It has been working great except when it comes to the use of transparencies and raytraced shadows. Basically any time I try to render a scene that contains objects with BESM applied and a Basic transparency with a light source that has raytraced shadows Lightwave freezes. I am getting the same results in 7.5 on both the Mac and the PC.

I have created a set of files that I can post if anyone is able to help out in testing this combination or helping to find a solution.

The only workaround I have found is to switch my light sources to use shadow maps and is not the solution I would have hoped for. It really limits my lighting setups, and isn't going to work for the final version of the piece I am working on.

Any help would be greatly appreciated. Thanks!

02-24-2003, 06:04 PM
Get them posted, i'll give them a try.


02-24-2003, 07:31 PM
Here are the test files. There are 2 objects and 2 scenes.

The only difference between raytrace.lws and shadowmap.lws are as follows:

1. The properties set for the lights, in raytrace.lws the light's shadow type is set to Ray Trace and in shadowmap.lws the light's shadow type is set to Shadow Map.

2. The render options in raytrace.lws has raytrace shadows set to on and in shadowmap.lws it is set to off.

If anyone can help out with a solution I would be forever grateful! This is a big deal on a big job! Thanks again.

02-25-2003, 08:48 AM
The raytrace should freeze LW when i press F9?

Hm, both work fine for me...even with multiple threads.
(have a dual Athlon XP 1800+, 1GB RAM)

When you say "Lightwave freezes" do you mean just Lightwave doesn't react but you can kill it? Does it hang with 100% (or maybe 50% in case of a dual system) CPU usage?
Really don't know what your problem could be...other plugins are not applied, and screwed installations on both PC and Mac...

02-25-2003, 09:14 AM
On both the Mac and PC Lightwave stops responding but I can kill the app on both yes. It strikes me as strange as well, but for some reason everytime the raytrace.lws will hang lightwave. I've recreated the file countless times and every one does the same thing on both my systems (Mac G4 667 1GB RAM, PC 600 MHz Athlon 1GB RAM).

What version of LW are you running and what version of BESM? What time does it take for the image to render that uses raytraced shadows?

02-25-2003, 09:31 AM
I tried both your scenes and did not have any problems but when I looked at the settings for the besm shader it had to create default settings(I havent used it before) perhaps if you knock your shader settings to default you might have some joy

02-25-2003, 09:50 AM
I tried both removing the preferences file for BESM on the Mac and setting it to default from within LW but it still crases on the raytrace.lws render. Are there any other preferences associated with LW that might be causing the problem?

Some more info about my setups, both the Mac and PC versions of LW were installed from the 7.5 CDs. The Mac LW version is build 572 and BESM version is 1.10.6. I have no other 3rd party plugins installed except for the ones that are included in the main installer for the app.

When I try to render the scene on the mac the Render Status dialog appears and then the app hangs. At this point I can quit the hub without getting the Lightwave applications are still running warning.

My PC is disassembled until we move to our new office on the weekend. So I can't provide any more info on it.

Any other ideas?

02-25-2003, 09:52 AM
Lightwave 7.5 (build 572, demo mode), BESM 1.1 (1.10.6 the one that shipped with 7.5, couldn't find a newer version on celshaded.com)
Rendertime is 1.9s

Just tried with LW 6.5b and the BESM 0.93b, but it kills LW already when i try to apply the shader, no matter what scene. LW sticks to 50% cpu usage (blocks one CPU) and you can watch the free memory go down from 800MB to less than 10 :D
Donno what's up with that, guess the "fixed small memory allocation error" wasn't the only one to fix.
The 1.1 from 7.5 doesn't work with 6.5b, refuses to start.

02-25-2003, 11:06 AM
Okay, I tried a few more things and still no luck. I am about to do a complete reinstall and see how it goes.

If anyone else is able to download the files and test them it would be great. Also, for those who have tried the files and had them work successfully did you install 7.5 from a CD or run the updater on an old version of the app.


02-27-2003, 04:31 PM
I reinstalled LW 7.5 after removing the app and all preferences but am still having no luck. The raytrace.lws keeps causing LW to crash the moment I try to render the scene.

Has anyone had LW lock up from trying to render the scene, especially anyone on a Mac running 10.1.4, LW 7.5 build 572 and BESM version is 1.10.6?

If anyone else can confirm the results they are getting it would be great! I really need to figure this out as I need to use this setup for the best results on this piece.

Thanks again.

03-03-2003, 07:03 PM
Sorry to keep pushing this thread but I still can't get raytrace.lws to render. I am really hoping to sort this out, and if anyone has any ideas I would be extremely grateful.

I have tried reinstalling the app a couple of times now, each time removing all preferences files as well, but still no luck. I don't know what it can be. My PC will be back up and runnning tomorrow now that the move is complete. I will be trying to reinstall on that system as well, but it strikes me as strange that it is causing both systems to crash.

Are the BESM.p files cross platform? If so could someone who can render raytrace.lws without crashing email me one or post one I could download to see if that fixes things. Realistically I don't think it will especially seeing that it is occuring on the Mac and PC, and it is doubtful both install CDs had corrupt files.

03-03-2003, 07:24 PM
Are the BESM.p files cross platform?

No, plugins can't be platform independent, at best their source code is. Would be cool if the same binaries work for Mac and PC...

But i still have no idea what your problem could be. Am just hunting bugs in my own plugins...

03-03-2003, 07:43 PM
Just tried them both on my 733 p3, Win 2000 pro sp2, LW 7.5, BESM 1.1,

Raytrace.lws renderd in 5.2 sec
ShadowMap.lws in 4.8 sec

Worked fine for me. Have you tried updating your OS and Graphics Drivers.

Sorry donít know what it could be.

03-04-2003, 08:04 AM
Thanks for posting the renders it made me realize something, in both images the ball should have a shadow.

In the raytrace.lws file, ray trace shadows must be on in the render options (I am sure it was set to on, but maybe not). Only then will the render crash, there is no problem if it is turned off. I think there is a problem in BESM with how it handles both shadows and transparencies together.

If anyone could test this and verify it that would be great. I am pretty sure it isn't just me, but then again you never know. A posted image of both renders including shadows would be great, or a confirmation of the crash.

Thanks again.

03-04-2003, 08:27 AM
uhm i just noticed something, when i loaded the scenes it seems it loaded another object named "box" in my objects folder, it had no BESM shader assigned of course. Just wondered why his box is blue...
But with th correct box it renders fine too, but takes 3.2s :rolleyes:
with a single thread only 1.8s...what do we learn from this? BESM is not multithreaded *lol*

Anyway, and no, the raytrace doesn't have a shadow because it's too bright for the cel shader, if you turn transparency down to 20% it has a shadow again.

03-07-2003, 10:57 AM
One last call for help.

I have tried reinstalling both my system and lightwave from scratch, with the same results whenever I try to render a scene that contains an object with BESM as well as transparency and a light source with ray traced shadows. I don't know what else to do, and I really need to get this to work!

Other people have had success when trying to render this scene, has anyone who has rendered the scene successfully used OS X 10.1.4. If so could you please post a confirmation of success, other wise I am going to keep trying to get a hold of LW tech support, who I have yet to hear back from.

From what I can gather it looks like a loop that the app gets caught in when trying to a render a scene that fits these criteria. While running "top" through terminal, as soon as the render commences LW maxes out the CPU usage at 90-100% even though it fails to respond.

Again, any help would be greatly appreciated.