View Full Version : Where do I find LW 9.2?

11-24-2008, 11:40 AM
I have a plugin that needs LW v.9.2. I can't seem to find a download in my registration downloads. Anyone want to throw me a bone? :)

11-24-2008, 12:11 PM
sorry I don't speak english... but... the link:


11-24-2008, 02:19 PM
Thanks a lot but I don't see any software on there related to LW9.x

11-24-2008, 02:42 PM
You may want to try that one (ftp://lw92betadownload:[email protected]/LightWave_v92_Beta_win32.zip)

Hope that helps

11-24-2008, 03:23 PM
Thanks a bunch, I'll give that a shot!

11-24-2008, 04:28 PM
That appears to be a 9.3 beta program. At least that's what it says in the upper left hand corner of the UI. Sadly it didn't work with Smart Morph. I keep getting a crash if I try to open a scene with Smart Morph Applied.

11-24-2008, 05:02 PM
That appears to be a 9.3 beta program. At least that's what it says in the upper left hand corner of the UI. Sadly it didn't work with Smart Morph. I keep getting a crash if I try to open a scene with Smart Morph Applied.

Try emailing Pawel Olas about this. Even though he isn't developing new plug-ins for LightWave, I think he is still supporting his existing products.

Let me know how it goes.


11-24-2008, 06:13 PM
Yeah Pawel knows, I've been exchanging emails with him. He told me to try 9.2 so he may not respond till I try it with that version. The plugin works fine till I try to reload the scene then I get an instant crash every time I reload it. I PMed pooby on this too, to see if he ever had this problem with Smorph. So, I'm actually trying to get my hands on the actual release of 9.2, can't find it.

11-24-2008, 07:24 PM
He just replied again, he just moved into a new place so you know how that goes.:)

"Hi. I'll install demo of LW on my box at work and check if I
experience the same issue. I just moved to a new house and my computer
at home is still in a box somewhere.

Pawel Olas"

11-25-2008, 05:13 AM

second link down

It's on Newtek Europe's site so hopefully you can download from there. Failing that I'll upload it somewhere for you....or download a torrent and use your dongle instead of the crack/keygen/whatever, I expect that it would work as a last resort.

11-25-2008, 03:27 PM
Made a little progress but not much.

Pawel: "just tried to open one of the sample scenes in latest LW (demo) and
had no problems. The only difference is that I used unlimited version
of the plugin. Please try it to see if it makes any difference for

Me: "Okay, well I had no luck with the unlimited version of Smorph either when using 9.3 and up. I deleted all the config files thinking that might be causing the problem but it didn't help. However, I downloaded and installed LW 8.5 and it does work fine in that version. So I dunno what the problem is with 9.x programs and Smorph.

Like I said before though, some of your sample scenes do open in the LW9.x programs EXCEPT the texture smorph scene and sometimes the arm muscle morph scene will not open either. Do those particular scenes work on your computer?"


11-25-2008, 05:48 PM
Me: "Does this scene open in your LW Demo??



Pawel: "you are right. LW crashes. I'll investigate it."

11-26-2008, 03:02 AM
I had very similar problems with trees designer and eventually re-installed 8.5 to use it...but, shortly afterwards, I managed to get it to work with 9.3.

Here's my CGTalk thread on how I did it (more luck than judgement): http://forums.cgsociety.org/showthread.php?f=5&t=622443

It might help you to figure it out.

01-05-2009, 05:22 PM
Work around for crash on scene load:

"yea I know about it. I spent endless nights trying to fix it but the
crash happens in LW routine not mine. I have a workaround for it. I
know it is not the best solution but at least it is some solution.

if you open any scene with smart morph that doesn't use mixer (no
envelopes) it will not crash LW. then open SM interface that is
attached to an object in the scene. Close it and load the scene that
was crashing before (without restarting LW). It worked here every time
but it doesn't make any sense to me. Opening SM interface has nothing
to do with the bit of code that is crashing LW (loading envelopes from
a scene file). And the problem didn't exist in LW 7.5 that makes me
very suspicious.

Once again I'm very sorry for the problems you are experiencing but I
was unable to find any solution for it so far.
Pawel Olas"