PDA

View Full Version : plugins and education version



gumbytrain
11-20-2008, 09:33 AM
Will purchased plugins work with the educational 9.5 version of Lightwave?

I was looking at LWCAD, for example.

BeeVee
11-20-2008, 09:42 AM
Yes absolutely. Commercial plugins tend to be locked to the dongle and you have a dongle with your educational version, so no problem.

B