View Full Version : Problem Upgrading Mac LW9 to 9.3.1...

10-28-2008, 06:07 AM
The explanation is a little long, but I hope this is something simple...

I did a LW9 reinstall on my Intel Mac. I first installed the LW9 Program CD, which creates a "Newtek" folder in "Applications", which has a "Lightwave 3D 9" folder then a "Programs" folder where the LW apps are.

I also installed the Sentinel drivers for the USB key.

This is the default installation from the CD.

I then ran "Register Lightwave" and created my license.key file, and was able to run both LW and Modeler 9.0 without a problem

I then downloaded both the 9.3 and 9.3.1 updates from Newtek.

They both unzip into a ".DMG" file which has a "Lightwave 3D 9" folder and an instruction to drag it over to the "Application" folder. I did that for both updates.

When I tried to run Lightwave from this new folder, it says it can't find the license key and runs in discovery mode. Since there wasn't a new 9.3 "Register Lightwave" app, I copied the license.key file from the LW 9 program directory into this folder, but still had the same problem.

I then tried copying the new folder with 9.3.1 into the LW9 Newtek/Lightwave 3D 9/Programs directory. This just created a mess - 9.0's "Lightwave" is now "Layout" in 9.3.1 and it appears some files aren't in the same places by default.

I am certain this is operator error and I'm just overlooking something simple.

If anyone could give me the step by step on installing the 9.3/9.3.1 update over a LW9 CD install I would be really grateful....

Best Regards,


10-28-2008, 06:11 AM
try this thread


10-28-2008, 07:05 AM
Thought it wasn't actually about my install, there was a key piece of info there that took care of things:

The license.key file for a single user, and user-specific settings should go in:


Any license.key file you want all users to have access to, and machine-specific settings should go in:


Thanks for pointing me there - I really appreciate it.


-john m

10-28-2008, 09:48 AM
No probs-glad it helped. Ive bookmarked that thread just in case im faced with having to re-install. Its a right ball ache!