PDA

View Full Version : Issue with Materials & their Bump input



Captain Obvious
10-17-2008, 09:47 AM
Certain nodes take the bumped surface normal, rather than just the geometry-based smoothed normal, into account. Diffuse, specular & occlusion shaders are prime examples of this. A Lambert shader in your node tree that's not connected to anything will still take into account whatever you've plugged into the Bump or Normal input of the Surface node, or whatever stuff you have in the old-school bump layer. However, if you disconnect and remove all the bump and normal information from the Surface, and instead do it all with Materials, the following problem rears its ugly head:

Any shader plugged into a Material will completely ignore the bump input of said Material. If I plug a bump map into a Delta node and stick some sort of bump-respecting shader into it as well, I would want the shader to take the bump into account. At the moment, this is not the case. I was hoping to be able to use the Material Mixer and Switch to mix different Materials together, making my node trees less messy. However, because the Material's bump channel doesn't change the bumped normal of upstream nodes, I cannot do that. If I want to use Materials, I'm still stuck mixing & blending the bump channels independantly, and plugging them all into the Surface node's Bump input. This is a very inefficient way of working.

Surely it would be better if the a bump plugged into a Material changed the bumped normal of all the upstream nodes as well!


PS. I haven't tried this in 9.5. It's certainly possible that it's been fixed since 9.3.1, the version I'm using.