View Full Version : joint move,tip move, bone twist

10-15-2008, 07:29 PM
I recently purchased LW 9.3 and then downloaded and installed 9.5.

When I invoke joint move, tip move or bone twist the extra display ie the yellow line etc, is not visible through, or inside the mesh.If its outside or not behind the mesh it's fine.
I'm reasonably certain it's a setting somewhere that I can't find because if I give the relevant surface as little as 0.001% transparency it works as expected.

Anybody got any bright ideas, I'm fresh out?

10-15-2008, 08:04 PM
All I can suggest is turn on bone xray, or ENTER BONE mode.

These tools you are referring to, I never liked one bit. There's no undo. They were difficult to control in perspective mode. Just frustrating, so I never used them.

With LW9.5, I HIGHLY recommend when you are rigging, to use joints. You will find that they are easier to manipulate and ease most (not all) frustrations when rigging. And with joints, you no longer need these outdated, poorly made tools.

10-16-2008, 01:28 AM
To furtherwhat adam said,

I've tried numerous times to use those tools with joints, and I can't seem to get them to work for the life of me. They still work with Z-bones, but in no way do they work with joints.

Also, adam, just one thing, as much as I agree with you on those tools, I did (sometimes) find them useful if, and ONLY if, you used them in an orthographic viewport (side, front, etc.), perspective viewport never worked well with them.

10-16-2008, 07:22 AM
I constantly use the bone tools. Ive rarely if ever had issues with them and much prefer them over editing skelegons which have far more gotchas IMO. They work great with Zbones but apparently joints werent created with those tools in mind. I wish that when new features are added they do so in a way that supports or works with whats already there. If not then redo them....oh well..

Mr Rid
10-22-2008, 06:25 PM
Have only needed to use Joint Move once before awhile back. Am trying it now on a complex rig and cant get it to work. Every time I exit Bone Edit, all the children have moved(?). Dont know what I am missing.

The other problem is when your object is deformed during a Bone Edit. I wish it would just freeze deformations in place while you repo bones, but instead it disables bones and IK so the object moves and I cant see where I am lining up to. Have to save Xform on the model, and load it in as a guide.

10-22-2008, 07:22 PM
Joint move shouldnt effect that bones children. Tip move will do that. Which version of LW are you using?
Once youve adjusted a bone using joint move or some of the others the bones need to be rerested.

Mr Rid
10-22-2008, 07:51 PM
Joint move shouldnt effect that bones children. Tip move will do that. Which version of LW are you using?
Once youve adjusted a bone using joint move or some of the others the bones need to be rerested.

Yeah, it seems that the whole chain re-resting after only moving a joint or splitting a bone, is the problem. The bone tools operate on the assumption that your model is not deformed at 0. If it is, then the deformations are thrown off when the chain is re-rested.

Is why it would allow more control if it would freeze everything in place during an adjustment instead of auto-disabling bones, IK and re-resting... which also incurs crashes during bone splits and fuses that I get regularly.

Am in 9.3.

11-19-2008, 10:09 AM
Same problem here on a Mac....

cant see what i am doing with Joint or Tip Move...

11-19-2008, 08:32 PM
Try using the tools with your viewport set to front face wire frame. You'll find those tools much easier to see. :)

11-20-2008, 02:36 AM
Yeah, that tool used to be visible through the mesh but it changed in 9.5 (But that was also when I upgraded to Vista64 so I figured it may have been a graphics issue)

When I upgraded it changed.

But also found the solution to use wireframe a help.

Also remember that tip move will nudge the rotation of the bone affected so make sure and do shift p again to center out your rest rotations again.

Mr Rid
12-25-2008, 07:40 PM