PDA

View Full Version : Registering Lightwave 9.5 ...



darkMason
09-27-2008, 05:40 PM
I hate this to be my first post ... but so be it ...

OK .. first a bit about me (since this is my first post, and it's relevant). I've been programming for 20+ years; 6 of that time in software/hardware verification, and 2 and a half years of that in hardware/software upgrades/installs (see where I'm going?). Through all of this time I've had a fascination with 3D, which is why I currently have Lightwave (my 6th package in those 20+ years).

Anyway, I installed and attempted to register Lightwave 9.5 today, and it just isn't going as planned. I just built a new PC, so I first installed 9.0 and registered it (using the seperate utility) without any issue. I then installed 9.5 and things started to go bad ...

I installed 9.5, and at the end of the install, the installer asked to update the sentinel drivers. I said 'yes' (yeah ... I actually said 'yes'), and they installed. At the end of the install, I said 'no' to the immediate reboot (which is probably a good idea because the lightwave installer hadn't had a chance to finish and config the uninstaller). After a couple second of disk activity, the Sentinel installer fails, and says that I should re-install it. I let the 9.5 installer finish, and rebooted ...

Wanting to make sure that I had the latest, I grabbed 7.5.0 from the Sentinel site (which is later than 7.4.0 which comes with the 9.5 install package). It installs fine. I open the registration utility, put in my key (like I did with 9.0), it accepts it, I close it and start layout. 'Your license key was not found'. I close Layout and again enter my key using the registration utility. Same thing. I open 'Enter License' under 'Help' in Layout, and enter my key. I close Layout and open it again. 'Your license key was not found'. I close Layout, and copy my key from 9.0 to 9.5 (yes, they are installed in seperate directories). I again open Layout in 9.5 ... 'Your license key was not found'. Just for giggles (cause I'm feeling a bit paranoid by now), I open Layout in 9.0, and everything is still fine as expected.

It's funny. Back when I was working in verification doing upgrades/installs, I very quickly learned that the programmers used as little code as possible to do what was needed, because they knew that it was only going to be used once. It's too bad that they didn't realize that it's also the first thing that the customer (me) sees ...

Any pointers or suggestions would be appreciated ....

darkMason
10-01-2008, 07:35 PM
Can someone at least confirm that the 9.5 version layout window title says:

Layout NewTek LightWave 3D Build 1431 (Win32) 22-Jul-2008

... which seems kinda funny ... I would have thought it would say:

Layout NewTek Lightwave 3D 9.5 (Win32)

I have contacted support, but no reply yet ...

GregMalick
10-01-2008, 08:06 PM
I had troubles with the LW9.5 sentinel driver.

I ended up uninstalling LW9.5 - then reinstalling LW9.0 from the CD and then doing a new LW9.5 custom install saying NO to the sentinel driver update (oh and I said install the the SDK too).

That worked for me.
Not at my home PC so I can't say what the header says.
Maybe another poor soul will chime in with that info.

darkMason
10-02-2008, 06:17 AM
Thanks Gregory,

I've done the complete un-install/re-install 9.0 and then 9.5 twice now, but both times I've installed the latest driver during the 9.5 installation... which is what it seems everyone else (including the FAQ) says to do ...

But I'm willing to try anything ...

BeeVee
10-02-2008, 06:59 AM
Hi darkMason,

1431 is a beta version. If you are signed up to the open beta, you must look in the second section in your My Downloads page for release versions. 1455 is the build number for the final 9.5 that works with your LightWave 9 license.key (and yes, it just says 9.5 in the title bar).

A couple of points:

* 9.5 is a complete installation in its own right, you don't need to have any other version of LightWave installed to install it;
* www.setupmykey.com always has the latest Sentinel driver (7.5.0 at time of typing)

B

darkMason
10-02-2008, 12:49 PM
DOH ...

Interesting ... the 'real' 9.5 was not available on 'My Downloads' page 2 days ago (just 9.3 and 9.3.1 was ... or I was hallucinating), which is probably why I assumed that the 'beta 9.5' was the final (after all, it didn't say 9.5.1 beta).

Anyway, I will install the 'real' 9.5 tonight and give it a shot.

Thanks BeeVee.

darkMason
10-03-2008, 08:29 AM
Thanks again Ben,

No issues this time ...

JeffrySG
10-03-2008, 09:03 AM
Yay! :)