View Full Version : Can't stretch in Z axis using mouse.

09-24-2008, 12:23 AM
If I'm not wrong, in older versions of Lightwave Layout I could stretch an object in the Z axis with the mouse, locking the X and Y axes. Did something change in 9.5?

09-24-2008, 11:40 AM
In Layout or Modeler?
In Layout I would just hit 'h' and position the cursor over the z axis and drag. In Modeler just hold ctrl and drag up or down within the top viewport (or left-right in a side viewport).

I don't think anything's changed unless I'm misunderstanding your problem.

09-24-2008, 11:45 AM
Problem is in Layout: Using the z axis handle it works but before you could click anywhere and make the stretch in Z.

09-24-2008, 03:11 PM
Works fine here.

09-27-2008, 03:53 PM
I just tried with a 9.3.1 and it works but with 9.5.1 it doesn't.

09-27-2008, 04:22 PM
Works in 9.5.1 for me, can you do a screenshot or movie to show the problem??

10-01-2008, 02:46 AM
Ztreem: I don't have a program to record a video and a screenshot won't show what I mean. I just found that if you are in camera view and your camera Heading is at 0 , the object won't stretch in Z axis but if I change the heading to something different than 0 it works. :(

It was different in 9.3.1. Just locking Scale X and Y, I could scale Z moving my mouse up or down.

10-02-2008, 06:46 AM
OK, I didn't test it in camera view at heading 0, I usually work in perspective view. Did this work before 9.5? Then make a scene showing this bug and send it with a desciption to NT.

10-02-2008, 09:17 AM
check maybe you have locked Z axis

10-02-2008, 11:04 AM
I have 9.3 installed and it works fine.
No, Z axis is enabled. I usually use this to make a extruded text or logo longer and animate it.

10-02-2008, 10:36 PM
Ya, somthing is strange...only in camera view. Here is what I tried.

1) Looked through camera doen the Z axis.
2)Selected object with Z only, tried to strech with mouse cursor not on on handle and nothing. No streching of object in Z.
3)Selected camera, moved it 45 degrees to the so I can see the side of object.
4) Selected object in scale mode and moved mouse cursor on screen and object streched along Z worked fine.
5) selected camera moved it back to look down the Z
6) selected object and streching down the Z worked fine.

Something is worng with the first time streching.
9.3.1 worked fine and did not have this issue.
Another Note: about the handels:
In 9.5 with the XY channels locked the handels disappear, is this a new setting?
In 9.3.1 the locked handels just go to a dotted line state on the gizmo.
I guess it makes sense not to see the other handels, is this a bug or fix?