View Full Version : Pic Video MJPEG w/ VT3

08-01-2003, 01:00 PM
Just installed my new VT3. Windows plays my previously captured PIC VIDEO MJPEG clips but TED does not. Audio plays, but video locks up. Any ideas on how to get my video to work

08-01-2003, 07:54 PM
It's a bug, sort of. NewTek and PicVideo are aware of it. Meantime, try disabling the Size checkbox in the spline controls of your video clips. Some have found that made all the difference, though Ive no idea why since the problem is apparently related to something else entirely.

08-01-2003, 08:34 PM
There is also a checkbox in the codecs setup to uncheck as well. I don't remember what the name is but if you look it should be obvious.

08-02-2003, 09:02 AM
That was something to do with fileding, but I'm not sure based on what I've read that both are necessary to sidestep the issue, Robert. Someone who has this licked will likely step in here .. :-p

08-02-2003, 03:11 PM
I hope so because I hit a few I couldn't play back and would like to have a resolution should I need.

And I thought it was a flat out would not play issue, as Jennifer(?) has eluded to.

Oh well, it all works now on my end... ;)

Steve, take care.

08-03-2003, 02:09 PM
Originally posted by UnCommonGrafx
Oh well, it all works now on my end... ;)

Steve, take care. Newly married AND time for work Robert? BTW, big belated congrats! :)

08-04-2003, 07:58 AM
Still not working on this end. Can you give me settings, operating system??? What do you have that it works on?

08-04-2003, 08:13 AM
Do you have access to the Beta forum? Lots of info there.

It seems that maybe downloading the Mainconcept codec willl get the older picvideo files to work.

Snippets from a conversation:

"It seems I can get my old project to play. If I go into each clip and disable size, up comes the video."
"Interesting, James - I guess, as a workaround for now, you could do up a ToolBox preset with that setting."

"<<<<<If you open PicVideo's settings panel and go to the ADVANCED tab see if the "2 Fields etc" has a check mark (it's ON by default). If you UNCHECK this box then when you capture using the Codec it plays back fine>>>>
Same here, it works fine if the clips are recorded with that option de-checked."

Hope that gets you moving...

08-04-2003, 10:16 AM
Did not beta test this round.

Got an answer from Andrew Cross that it basically will not work but they hope to find a solution with PicVideo. So I can either wait , go back to T2 or start from scratch on the two projects I have.

Thanks for all replys.

08-04-2003, 10:58 AM
Maybe i'm missing the point here - is it just older clips recorded with T[2] that are not working? Because I just tried recording to PicVideo M-JPEG on my VT[3] and it's working just fine...

If it's only older clips that fail, somebody want to post a short one I can experiment with?

08-04-2003, 11:27 AM
Right, Steve. Those of us that were using it before have this sniggle

08-04-2003, 11:42 AM
Given Andrew's explanation of the underlying reason, that seems passing peculiar. Why would a clip recorded using the codec with T[2] fail, but one recorded with the same codec with T[3] works, I wonder?

Paul Lara
08-04-2003, 04:25 PM
The problems with decompression of these files occurs when VT opens a file written by PICVideo, and has a bottom-to-top 24-bit header, and VT requests it be decoded to YUV. When VT queries support for this operation the decoder returns 'success' but when the frames are decompressed it fails.

We have documented this information, and are sending specifics and sample files to PICVideo so they can resolve this.

We considered a work-around to the problem, however that would have resulted in requiring VT to force decompression of all MJPG files (which is a standardized file type) in RGB color, which is significantly less efficient and has less image fidelity for video applications. This work-around would have also negatively affected codecs other than the one from PICVideo.

Yes, these files did play in Video Toaster [2], but only because they 'fell back' to RGB color even though the codec was reporting YUV support.

We'll be working with PICVideo on this problem and hope to report back with a solution in the near future.

08-04-2003, 09:38 PM
This still doesn't explain why Newtek has chosen to disable a codec that worked PERFECT in VT[2].

I used PicVideo M-JPEG quite heavily in VT[2] and it never failed me, and without question, with the Q set to 20 it was superior to DV encoding.

Anyone who owns PicVideo's M-JPEG codec, which was THE recommended one by Newtek for VT[2] anyway, wouldn't care at all about other M-JPEG codecs anyway.

Now I'm hearing from Steve that it does work, so does it work now or not?

I don't really care if it goes to RGB based on the quality it gives me, which is VERY high. And honestly, I've heard it works fine in other NLE applications.

Newtek shouldn't censor codecs that have proven their worth in past Newtek products. VT[2] compressed or uncompressed "any AVI codec"...

08-05-2003, 06:42 AM
Eugene, I feel the same way and did use this codec all the time also with excellent results. After much time and effort and not doing the beta program this round here is what I have found out.
No matter what you choose for settings it will not properly play. However the mainconcept Mjpeg codec will play any previous captured clips with the same quality and does handle the YUV decoding but does not allows for any high quality capturing. If we want to use PICvideo mjpeg we are stuck until picvideo changes there code to properly export YUV or newtek finds a work around to allow VT3 to use RGB color space with codecs. :(

08-05-2003, 07:05 AM
I wish someone could account for the fact that it (PicVideo, at Q19) is working perfectly on my system. Could it simply be that I did a fresh installation recently (having built a new T[3] host system)? There must be some explanation why others have a problem and I don't...

08-05-2003, 07:16 AM
It's now working perfectly on all our machines. What's not working is the older files captured under VT[2] at default. That is unless you also install/have installed the 'other' codec, mainconcept.
I wondered at this myself when the thread came up in beta 'cuz mine were working. Unbeknownst to me, it's because I already had it installed.

It's a sticky wicket, to say the least.

08-05-2003, 07:38 AM
The picvideo mjpeg codec will work in VT3 for capture and play however you have to set it to progressive, or set it so it does not use fielding. This basicly gives you a progressive capture thus also chaning the way toaster handles the header and decompression. For NTSC I still would prefer the crisper look and feel of a interlaced image.

08-05-2003, 07:44 AM
Originally posted by jennifertigges
The picvideo mjpeg codec will work in VT3 for capture and play however you have to set it to progressive, or set it so it does not use fielding. See the thing is - I haven't done that. Capture is set to 720x486i, and I have not disabled the "2 fields if more than 240 lines" setting in the codec's own advanced panel.

James Moore
08-07-2003, 01:35 PM
I just did some work using q19 in VT3 and it worked fine. I'm wondering if q20, which Eugene likes so much, is the culprit?

08-07-2003, 02:04 PM
Did you have it set to 2 fields/interlace.

Interlace still does not work for me, If some people are getting it to work and not others there must be some settings on the toaster or codec we are missing.

I wonder if someone that has it working on VT3 could post the settings or a little about the system it works on.

Or maybe newtek or Andrew might have an idea why it would work on one system and not another under VT3.


James Moore
08-07-2003, 02:09 PM
In the advanced settings for Q19, I've got Subsampling at 4:2:2 Luminance Quality 5, Chrominance Quality 6 and the 2 Fields If More Than 240 Lines is checked. Swap Decompress Fields and Force YUY2 Output are not checked and Codec Enabled is checked.

It captured and played back fine today. Mind you I never capture a file more than a minute today.

Rich Deustachio
08-07-2003, 03:03 PM
I have been trying to use PicVideo with Q20 seting and have had the green screen problems with both the 2 fields unchecked and checked. For short projects it seems to work, but when you try it with hour plus projects with many clips , the problems shows up. Also if you try to make a real slow cross fade for 2 seconds plus, it stutters. I have also noticed that with RC9 using it takes much longer for the green ready light to come on. Maybe I will go back to using it at Q19 and see if it helps.

James Moore
08-07-2003, 03:07 PM
I must say stuttering in playback is a problem for me. I'm just running back to back clips with dip to whites inbetween, sync audio and a music track. I've been rendering the beast for final playback. It cerainly is working well.

08-13-2003, 12:36 AM
I use Morgan Mjpeg instead of Pic Video, and I did have the green screen clips problem in T2, and it dissapeared in T3, my old clips made in T2 work great in t3, I could not capture to Morgan directly with t2, not reliably anyway, I've captured over 30 min now with t3. I much prefer the quality and size of Morgan Mjpegs than DV.

08-13-2003, 12:43 AM
I don't believe the green clips you're getting are a codec specific problem. It's an AVI reader issue that should be fixed soon.

As for my beloved Q=20, realize it takes A LOT more playback resources than Q=19, so your system may not support it in real-time for multiple streams for very long, depending on your system's specs.

As for why PicVideo works for some people and not for others, the prevailing theory is that older versions of it work, new ones don't.

As for Newtek, it is not a recommended codec until the creator of it corrects the bug.

08-13-2003, 05:51 AM
Originally posted by ScorpioProd
I don't believe the green clips you're getting are a codec specific problem. It's an AVI reader issue that should be fixed soon. Ahah - Steve may have been right again (for once ;) )

Mike Watkins
08-18-2003, 04:27 PM
We found a work around for any problems using PicVideo's MJPEG codec.

Please refer to this thread for more details: