View Full Version : Problem with animation keys and general movement

09-16-2008, 11:36 PM
Hey there,

I'm a long time Flash animator, and I've taken the jump to 3D with lightwave. But I've got a problem with my work flow conversion.

How do the animation keys in layout really work? I set a key, for example, on frame 20 with the camera moved down. So as expected, between frame 1 to 20, the camera moves down. But then, i want the camera to sit there for say, 20 frames, and then move again. So i move the slider to 40, and set the same frame as where the camera currently sitting, i don't move it at all. But the camera doesn't sit still for those 20 frames, it does a little loop in itself!

I then proceed to make another keyframe at 50, trying to make the camera move foward. Running the animation now, it looks as through the camera totally ignores the frame at 40 and just flies around without stopping at all.

This happens to me with characters, bones, cameras and objects. How in the world do I animate properly in 3D, and get things to stop and start when i want them to? haha.

Any help is greatly appreciated.

09-17-2008, 12:14 AM
The default way LW interpolates between keys is by using splines. This gives you a nice smooth motion normally, but if you want something to stop dead, then continue on you have a couple of options.

Adjust the Tension. If you press ctrl-g, you can drag left and right to adjust the tension on a keyframe. By setting this to 1, the camera will slow down as it gets to the key. If you do this at 2 keys, the camera will slow down and stop, then accelerate away again after the second keyframe.

Adjust the Continuity. Again press ctrl-g, but this time ctrl-drag and you'll adjust it. Set it to -1 for both keys and the camera will slam to a stop, then start off again instantly, unlike the smooth stopping you got with tension.

Set the second key to Linear. Open the Grpah editor and select the second keyframe. At the bottom of the graph editor, there's an Interpolation selector, it'll say TBC (Tension, Continuity and Bias). Set it to Linear instead and between this and the key before it will turn into a line.