PDA

View Full Version : Patch Confusion... Again



bradl
02-23-2003, 09:19 PM
I am running Build 3866. Want to install 3890. It seems like I go through this everytime, but I am unclear as to whether I should install on top of my orig. full version from the CD's (can't locate a number on that) that has been patched to 3866, or uninstall 3866 then patch to 3890. Last time I had to deleted the whole thing it got to be such a mess with multilple patches.

I hate to complain about updates (i.e. - keep em coming!!) but there are no clear install instructions ever. It may seem unneccesary to some but this is not some small piece of shareware, this is our means of making a living. A little guidance, even if redundant, is in order.

There was an install document that was available but it raised more questions than it gave answers to and has not been updated in a few patches.

Last thing, could someone list once again (in case I am missing something) the files, docs, plug-ins, pdf's, etc. that are recommended to be backed up before I start updating...


Thanks,

Brad

Scott Bates
02-23-2003, 10:56 PM
Look at the file name of the update. If it has a "P" in it such as VTP3890 then it's a Patch which is installed on top of what you've got - as opposed to a VTBxxxx which is a Build which has to have a clean install.

Back up all your project files (which you should keep outside of the VT2 folder anyway) and search the Skins directory for any that have Administrator (or your system name) as part of the file name - Prefs is one of them. Also look for Administrator "Favorites" or something similar which is in one of the File.... Skins directories; that has your TEd Hotlist in it. Sometimes you can put that back in and get your Hotlist back, sometimes it won't do it and you have to recreate it.

Paul Lara
02-24-2003, 06:11 AM
there are no clear install instructions ever.

For the forgetful and those coming to the downloads page for the first time, there has always been a link at the bottom that says Upgrading Video Toaster [2] software (http://www.newtek.com/products/videotoaster/downloads/PatchingVideoToaster.pdf)

This is fully explained, as Scott has also provided.

c111smith
02-24-2003, 12:26 PM
OK, so, umm, what if...
I tried upgrading to vtp3890 but got the three choices of Modify, Repair or Remove. Modify offered to reinstall selected or all components but didn't give a choice on which drive. It selected my drive for me, except it was the wrong drive. So I tried Repair. That ran by very quickly and had no discernable effect on the program. My system drive is different than my program drive & I suspect that is the problem here. Is it possible for me, the user, to be able to tell the installation program where to install 3890?

Paul Lara
02-24-2003, 08:34 PM
Originally posted by c111smith
OK, so, umm, what if...
I tried upgrading to vtp3890 but got the three choices of Modify, Repair or Remove.

Then the registry already thinks that 3890 is installed.
Sounds like you should uninstall 3890, then your base build, and try again.

Jim Capillo
02-25-2003, 08:15 AM
I also had somewhat of a similar problem with the system looking for all sorts of other files. The solution was to delete the Newtek folder in the registry and re-install 2881 (I think) then 3890.

Piece of cake..........;) :p

c111smith
02-25-2003, 01:31 PM
Thanks, guys. I tried to delete & reload already but still no-go. Maybe I didn't get the registry completely cleared of NewTek stuff. I'll try again.
Also, Jim, I'm not sure if I still have the build you mention hangin' around somewhere. Is there someplace it is still available for download?
Again, thanks for the advice!

Jim Capillo
02-25-2003, 01:54 PM
Originally posted by c111smith
Also, Jim, I'm not sure if I still have the build you mention hangin' around somewhere. Is there someplace it is still available for download?


I looked on the Newtek site and 2881 is not there. I think all those posted there are patches.

Send me an email with your snail mail and I will burn you a copy - as long as that's OK with the powers that be at Newtek........ my "other system's" manufacturers don't allow any copying of the software for ANY reason. As a matter of fact, I don't think I can even legally LOOK at the CD. :p ;) :D

c111smith
02-25-2003, 02:25 PM
I found it! 3866 was hiding in a folder I call "Stray Cats".
Thanks for the kind offer anyway, Jim. I'll try to get things up & running using your's & Paul's pointers.

c111smith
02-25-2003, 02:27 PM
Oops, except you said, "2881". Hmm, I'll try with what I have & get back to you.

Scott Bates
02-25-2003, 03:12 PM
You need a version who's file name is VTB[for Build]xxxx or (I think) any of the versions that you received on a CD from NewTek. I believe anything they send out on CD are full builds which will serve as a base for install-on-top Patches such as VTP3890.

c111smith
02-25-2003, 03:34 PM
Yeah, as it turns out I have a CD with vtb2881 on it. I uninstalled VT2 & all patches, ran Regcleaner, manually checked for any references to newtek, vt2, 3890 (that one took a little work!) & videotoaster. I then did a cold boot, loaded vtb2881, made sure it ran ok, then tried to upgrade to vtp3890. I got the same old screen asking to modify, repair or remove. I'm at wits end here. The old builds & patches work fine & I can get things done, but I want to stay current with features & updates.
BTW, just in case I had a bad exe or something, I deleted the unzipped package for 3890 & reloaded it from the original zip file, then tried the whole thing over again. Still no-go.
I figure there HAS to be a remnant of 3890 in the registry somwhere, but I'll be damned if I can find it!

c111smith
02-26-2003, 08:08 AM
I got 3866 to load up & will stay with that. Got work to do, y'know? Thanks for all the input. I'll try to figure this out at a later date. ttfn