View Full Version : Bone weight map doesn't stay applied

08-19-2008, 12:53 AM
Hey guys
I have a basic character thats nice and bonded. When I apply the weight maps to the appropriate bones in layout it works great :). However, these changes don't stick when I reload the scene (and yes of course I saved the changes before closing)

Any ideas why this is happening?

08-19-2008, 06:05 AM
There's so way of telling from the information you posted. Try exporting and reloading the rig--the weight assignments should be saved with the rig. If that doesn't work, do a simple test scene (i.e., deforming weight mapped cylinder with two bones) and see if the problem persists. If so, it might be a bug.

08-19-2008, 07:45 AM
Are you using Save Current Object.. or Save All Objects?
We've written plug-in SaveSceneAndAllObjects http://www.trueart.eu to make sure such things don't happen. Just assign it to a hot-key and press from time to time. There is also Increment version, which is bumping all objects and scene suffix, each save.

08-19-2008, 09:06 AM
Here is one possible issue.

In layout you can see all the weight maps in the scene. If the weight map is not part of the object you are using it with. It will not be saved. This is usually the problem when using bones from another object. I create null weight in the object that has the original bones in order to fix this.

08-19-2008, 05:09 PM
Thanks for the reply

I'm thinking it's just a bug. I tried the plug-in SaveSceneAndAllObjects and exporting and importing the rig with no success.

The character (a lego man) is made up of multiple objects each weighted appropriately. Once boned, I applied the weights to the bones and have a nice working scene until it needs to be reloaded

I shall persist

08-19-2008, 05:12 PM
Listen Castius, he is right.. You must have object to have storage for weight map..

08-19-2008, 05:54 PM

For example. I have arms.lwo, legs.lwo etc etc. Each of these objects have been weighted. They have then been assembled in layout and then boned. Am I running into a problem already?

08-19-2008, 08:11 PM
I fixed it but i suspect it may be a hack way.
In the base object a added some 1 point polys and added the weight maps to them. Loads fine now.

Is this the problem you thought I was having, Castius?

08-19-2008, 08:59 PM
Yup thats the one. And your work around is the way to work around it.

I think i submitted this as a bug, a long time ago. But we should submit it again.