PDA

View Full Version : I am having problems with the final render...



jnddepew
07-14-2008, 05:50 PM
While working on an animated movie I'm doing, I keep coming across a render error which makes the textures look weird. I can't figure out how to fix it. Here's a youtube video to show what I mean.
http://www.youtube.com/watch?v=DY8YzDu0we4

any help would be much appreciated.

hmm. youtube kinda messes up the movie. The flashing texture is my problem.
you can download the better quality here to better see what I mean.
http://www.mediafire.com/?m2mizmlid4s

thanks.

jnddepew
07-15-2008, 09:13 AM
here's a picture to better tell what i mean with the texture. Any help would be much appreciated. I'm using lightwave 8.5 by the way.

Lightwolf
07-15-2008, 09:23 AM
This looks like duplicate polygons taking up the same space. Check your mesh for those.

Cheers,
Mike

jnddepew
07-15-2008, 10:49 AM
Hmm, that's what I thought at first too, but I can't seem to find any. When I select one of these polygons it'll say I only have 1 selected and then I'll move it and there won't be a duplicate polygon there.
It's weird.

Lightwolf
07-15-2008, 10:57 AM
Hmm, that's what I thought at first too, but I can't seem to find any. When I select one of these polygons it'll say I only have 1 selected and then I'll move it and there won't be a duplicate polygon there.
It's weird.
Maybe any points that haven't been welded?

Cheers,
Mike

Edit: Make sure to select in wireframe, otherwise LW will only select polygons that face the viewport. It might make a difference... *shrugs*

jnddepew
07-15-2008, 02:19 PM
I think it has something to do with the lighting. When I have this model in a scene with a simple lighting setup it looks normal, but when It's in a scene with a complicated lighting setup, I get this effect, even on non-doubled areas. This is very frustrating

jnddepew
07-15-2008, 02:30 PM
Okay, I've found, through experimentation that when I turn off raytracing shadows the effect goes away. That's not good. What can I do without raytracing shadows??

jnddepew
07-15-2008, 05:35 PM
Okay. Two pictures for comparison: one with raytracing shadows off and one with them on.

Raytracing Shadows Off:
http://i170.photobucket.com/albums/u245/jnddepew/withoutshadows.jpg

Raytracing Shadows On:
http://i170.photobucket.com/albums/u245/jnddepew/withshadows.jpg

gfrederickk
07-16-2008, 05:04 PM
JND ---

Do you have multiple versions of your scene floating around? Or do you have multiple versions of the images stored locally and on servers?

I had a very similar problem a while back. I dragged my scene to a separate computer to submit it for render. Once I got it there, I made some fixes. The render farm produced some stills from files that were on the server.

Make sure your rendering computer can see only one version of the images files you're using and one version of your scene.

Could be the problem.

gfrederickk
07-16-2008, 05:11 PM
I looked at your movie again. It seems exactly like the problem we had. The problem definitely rested in conflicting versions of the scene. It resulted in some frames being rendered without the proper surface textures. Image maps dropped out. So what looks like a lighting problem really was s surfacing problem. Alternate frames not rendering the right specularity, etc.

Good luck.

gfrederickk
07-16-2008, 05:17 PM
Last thought ---

Remember that Lightwave holds a lot of info in memory. You may want to rename your scene and make sure your content directories are set.

toby
07-21-2008, 02:27 AM
Have you tried Unify polygons? You might have two different polygons made from the same set of points. Also turn off any double siding.

Do you have any shaders assigned to these surfaces?

jnddepew
07-21-2008, 10:55 AM
I have double siding off, i do seem to have a situation where there are some double poly's, but they are facing different ways, so without double siding, that shouldn't be a problem right? i tried doing a unify to the whole model. It said it had eliminated 187 polys or something but I am still getting some of these artifacts. maybe if i very meticulously go through and delete all the backward facing polys...

toby
07-21-2008, 08:48 PM
Yea, the backfacing polys could easily cause this. They'll cast a shadow on the frontfacing ones. First clear out a patch of them and render, see if that fixes it before doing the whole thing.