View Full Version : mdscan and mdplug .. still not fixed?

07-07-2008, 08:06 AM
I've seen this mentioned as far back as 2004 but have never needed to use it before now. I use MDScan to scan the displacement of an ocean object. Let it do its thing, and then load the saved .mdd file in with mdplug. Except it only works if I set the Sub-d order to Last which is an utter waste of time as I lose all my detail.

Does anyone know of a workaround for this other than doing the scan on a highly subdivided object in the first place? OR am I doing something fundamentally wrong.


And just for completion..

1. low res ocean object with sub d applied

2. in layout I set the display sub d to 6 with the displacement applied.

3. play it through as a preview (just incase although its apparently unneccesary)

4. load mdscan, give the mdd a name, let mdscan run through the frames.

5. open up mdscan to save the mdd file.

6. remove all displacement.

7 add mdplug, point it to the mdd file and bobs your giddy aunt. Nothing happens. Unless I set subd to last instead of first in which case it has only a rough average of the orignal displacement.

07-07-2008, 03:13 PM
Does anyone know of a workaround..
Yes, scan and play the mdd with ClothFX. That should work.

If you're using LW 9.x I'd recommend using Dpont's nodes MDD-Pointer and MDD-MetaPointer (http://pagesperso-orange.fr/dpont/plugins/nodes/Additionnal_Nodes_2.html) to play the mdd files. Since they're 'nodal' you're much more flexible.

07-08-2008, 03:53 AM
The clothFX worked great. Thanks. Its a bit flaky and slow though. It crashed half a dozen times before it eventualy gave me a complete mdd. But at least it plays back now.

And theres some excellent nodes on dponts site. Thanks for the pointer.