PDA

View Full Version : Particle Emitter Trouble



CMT
06-25-2008, 03:40 PM
I've been attempting to get these particles to behave themselves. But they are not cooperating.

I have the emitter circling along a path with it emitting particles which will end up rendering hypervoxel smoke. But after a couple seconds they all start orienting themselves in alignment with the path for no reason. It's creating some type of jitter effect in the rendering.

It has nothing to do with the hypervoxel settings. You can see they align themselves after a certain number of frames of existence, but I can't figure out why it's doing it.

I'm attaching the file here for anyone who can help me with this. I just want the particles to stay in the same orientation as when they were emitted. Here's (http://www.loadedbrush.com/Challenges/Newtek08/ParticleTest.mov) what it's doing when it renders with hypervoxels. It's very noticeable.

BTW, this test was done in LW 8.5 cuz I'm here at work. So I don't know if the problem exists in 9. I will see when I get home.

vfxwizard
06-25-2008, 04:10 PM
I just want the particles to stay in the same orientation as when they were emitted. Here's (http://www.loadedbrush.com/Challenges/Newtek08/ParticleTest.mov) what it's doing when it renders with hypervoxels. It's very noticeable.


Strange, that kind of jitter usually happens when using interaction. Anyway, to remove it, turn on "Use Particles Orientation" in Hypervoxels panel. Sorry but I can't remember if it was already available in 8.

CMT
06-25-2008, 09:39 PM
Thanks for the suggestion, vxfwizard. I tried that and it fixed the problem, but created a new problem. The stretch direction changed to how the particles were aligned rather than the direction they were traveling. They were stretched almost perpendicular to the direction. So I went back to what I had and tried something different.

I couldn't figure out why it was doing it, but I did find a way around the problem. It seems that when the particles just sit there motionless for several frames, they do that. They need to be in constant motion, however small, to keep their orientation. Could be a bug, I don't know. So I added another wind effector to it and it seemed to work without the jittering (plus it made it look better :) ). A gif was added to my contest thread showing how it turned out.