PDA

View Full Version : Does lightwave support Intel Macs now?



AutumnFire
06-25-2008, 11:12 AM
Searching, I found a number of articles indicating that Intel support would arrive in March. However, NewTek's System Requirements for LW still say G4 or G5. Can Lightwave Run on an Intel mac? Does it have to run in Rosetta, and if so is that mind-numbingly slow?

Thanks,
Ari

tribbles
06-25-2008, 11:25 AM
9.3.1 is the latest official version - Universal Binary mode is supported. Works fine.

And from what I've heard, Rosetta isn't too bad anyway (I've only used it in UB mode though).

AutumnFire
06-25-2008, 11:30 AM
Hmmm... NewTek's system reqs need updating, then? Or was I in the wrong place?

tribbles
06-25-2008, 02:06 PM
Probably needs updating - I've not really looked at the requirements; I moved over from Windows to Mac about a year ago, and knew that it worked from discussions here.

Chilton
06-25-2008, 06:19 PM
Hi,

What page did you find that on? It needs to be changed. We have a number of G4s and G5s around here, but a majority of our Mac kit is Intel based now.

-Chilton

tigerten
06-25-2008, 09:01 PM
The system requirements page under lightwave 3D for Macs says: G4 or G5 processor, G5 recommended. Under Operating system it says OS X 10.3.9 minimum.

There is no mention of Intel processors at all.

Jerry

Giacomo99
06-26-2008, 05:43 PM
Lightwave runs fine on Intel Macs. My experience is that 9.3 is pretty unstable and slow under Leopard, though, so if you want to run Lightwave on Leopard you'll need to enroll in the 9.5 Open Beta program.

JeffrySG
06-26-2008, 10:39 PM
It does say that...
http://www.newtek.com/lightwave/system_requirements/



LightWave System Requirements


Specifications subject to change without notice.
LightWave v9:
General Requirements:
System RAM: 512 MB minimum requirement, 1 GB recommended
Graphics card: nVidia FX 5200 series (minimum) or ATIFireGL V 5100 (minimum)
Graphics support: Full OpenGL (OpenGL 2.0 support, or ARB_shading_language_100
OpenGL extension in earlier versions, required to use GLSL features)
Graphics driver: Latest from chipset manufacturer
Dedicated video RAM: 64 MB per display minimum requirement, 128 MB recommended
Minimum resolution: 1024x768 minimum requirement, 1280x1024 recommended
Hard drive space: 230 MB for program installation (not including content)
Windows 32-bit:
Operating System: Windows XP
Processor: Intel or AMD
Windows 64-bit:
Operating System: Windows XP Professional x64 Edition
Processor: Intel EM64T or AMD64
System RAM: 1 GB
Macintosh:
Operating System: OS X 10.3.9 Panther
Processor: PowerPC G4 minimum requirement, G5 recommended

tribbles
06-27-2008, 10:48 AM
Well, it does say G4 minimum, and I guess Intel is "more" than a G4 - so it's technically true :)

Just not very clear (and would Intel be recommended now?)

AutumnFire
07-18-2008, 02:36 PM
Thanks for clarifying. I didn't want to go and buy the software and find out that it didn't work on my computer.

And, while the MacPro's chips are, in every sense "more" than the G4, there are tons of apps out there which were never updated for Intel. Those apps' system requirements would say exactly what Lightwave's site does right now, and those apps would be forced to run in Rosetta. That would not be good for LW.