PDA

View Full Version : Vertex Alpha Problem



Clockmaster
06-12-2008, 12:58 PM
Take a look at the attached images.
I create a vertex color map for the bright gray stripe of polygons, that is positioned 100mm over the dark gray plane.
Then I used the airbrush (but is the same thing with vertex paint) to paint the selected border points of the first image at alpha=0%.
practically I am trying to model a simple street on the ground, were the texture of the street gradually became that of the ground (from alpha=100% to 0%), a typical set up, I must say.
In OpenGl nothing happens, ok, the LW in OpenGl doesn't support vertex alpha, let's pass over.
I send the object to Layout, tap F9, and nothing (image2), also the renderer doesn't recognize vertex alpha.
Am I missing something? Please help!

Clockmaster
06-13-2008, 08:24 AM
bump
:)

Giacomo99
06-14-2008, 11:21 AM
This isn't an area I'm very familiar with, but when I open the "Two planes" model in Modeler and look at the "Vertex Alpha" map, it's completely blank. Every vertex has a value of 0%.

I suspect this may have something to do with your problem.

Clockmaster
06-14-2008, 02:42 PM
If you launch "vertex paint", You'll see that the color map "vertex alpha" is not blank: the borders appears to be black, actually.
By the way, in that model i forget to select the vertex color map in the advanced tab of the surface attributes. But this doesn't solve the problem:after selecting the appropriate map, in the rendering I only obtain that the street is lighter at the borders. Discussing about that on Spinquad, I have discovered that probably Lightwave uses the alpha parameter in vertex color maps for layering/blending purposes and not for transparency, as it would be useful in real-time applications (e.g. creation of landscapes for videogames).
In fact, if I open this example model with a real time 3d viewer, I only obtain the street borders to be black.
That is a real pity, and I wonder if someone knows a way to create a real vertex alpha map with lightwave.

bye

Clockmaster
06-14-2008, 02:53 PM
the correct object , scene and rendering.

toby
06-14-2008, 07:16 PM
If you want anything to appear transparent, you'll need to apply something to the transparency channel, not the alpha, unless you're making it transparent in a compositor instead of the renderer. It doesn't look like vertex paint can be applied to different channels though, use a wieght map instead. In the texture channels you'll need to apply a gradient set to weight map.

toby
06-14-2008, 07:23 PM
Sorry, I didn't read your post very carefully, to say the least.