View Full Version : Weird HyperVoxel Render problem

Ty Catt
06-09-2008, 01:15 PM
Weird issue- I am creating smoke for a welding scene and I keep getting a strange "shadow" that corresponds with the smoke.

Smoke created with Partticle emitter, nothing fancy.

Almost a really wide, dark outline to the smoke. It follows the contour of the smoke perfectly?... you can see it change shape with smoke width.

I am new to version 9.0, is it a bug with v9?

If it is so, any workarounds?:help:



06-09-2008, 02:10 PM
I think you have to tell us more and also show us what the problem is.
post a pic.
also what mode are you working in hv volume or sprite?

if you are using hv volume you might consider turning of the volumetric shadows under the shading/advanced tab.


Ty Catt
06-09-2008, 02:23 PM
Sorry, I meant to attach the image the first time.

I am using HV with sprites. The smoke is grayish-white, under 200 particles.

Checked old threads; tried to change camera settings, slices in the HV surfaces to no avail.

I cannot think of ever having this problem in old versions.

Thanks for any help...

Actually, the sparks (also created with HV as sprites) have weird outlines in the shadowed areas. See them?


06-09-2008, 03:29 PM
well I think it is the bucket object your having that is casting shadows on to the sprites, unfortunatly theres no way to turn of shadows for sprites, except
for turning of raytrace shadows in render globals, it might help changing the level of sprite slices you are using, not sure but if theres more than one slice it will most likely pick up more shadow, so set the slices to one if itīs not allready.

the sparks seems to be somekind of opacity issue, not sure but I believe you might have the opacity set very low and thus the dark background will show
throu more in the sprites, you could raise the opacity level to prevent light and background shine throu, but you might need to compensate other values to keep the original look.
Or it might still be the shadows from the object affecting.


Ty Catt
06-10-2008, 10:54 AM

Well, I figured something out.

If I render out the anim through Save RGB, the weird shadow goes away. It only comes out as an uncompressed .AVI?

Who knows?

I'll just roll with it as an RGB export I guess.

BTW, the HV was set to one slice, and I had three point lighting set-up, so the object wasn't casting any shadow on to the sprites.

Thanks for your help.


Ty Catt
06-11-2008, 10:12 AM
This error is getting even buggier.

It still renders even as saving out RGB.

Sometimes it renders out and sometimes not even as a F9 still.

VIPER enabled or disabled seemed to activate this new result.

I have tried everything.



06-11-2008, 11:50 AM
I guess you canīt post the scenefile for checking it up?

is this problem only showing in renders? and not in viper?


Ty Catt
06-11-2008, 12:05 PM

It's tricky-

This animation is for legal purposes and I cannot post it.

That's why the thumbnail was as obscure as it was.

The problem ALWAYS shows up in the render, and occasionally on just a plain old F9 check.

VIPER doesn't really show it either.

Maybe I'll have to change to Volume instead of Sprite.

Thanks for all your help, maybe I'll figure it out somehow.


Ty Catt
06-11-2008, 01:54 PM
I changed the camera type from Classic to Perspective and real basic AA.

Seems to render OK.

We'll see in the morning!

Thanks, again,