PDA

View Full Version : FX sources not scaling/warping in LW LS Generator



billmi
05-19-2008, 10:37 AM
Preliminary live sets that I built in the LifhtWave Live Set generator were for just the input channel and rendered no problem.

But... Rendering some livesets that have the supplied TV set object in them from the Demo Set example scene, the FX channnel is being keyhole mapped (i.e. keyed, rather than scaled and positioned) even if the Keyhole Matte checkbox is unchecked (which should not affect the FX channel surface anyway.) I've even re-surfaced the TV object in Lightwave, auto setting the texture scale, and still the problem persists.

As usual, I'm probably overlooking something obvious - but what?

Thanks.

UnCommonGrafx
05-19-2008, 11:29 AM
Man, some language needs to be cleared up!

FX or ffx is going to start getting very confusing on this forum...

Sorry Bill, no ideas on your subject...

joseburgos
05-19-2008, 01:01 PM
Any surface using the LS texture, has two places it can put into.
One is the color the other is transparency.
Sounds like you have it on transparency as well.
If you do, then it will have the livematte function included with it.
To just have the FX as a texture, then the LS texture need only be placed on the color texture of the surface.

Also note, this may be the preset LS for FX you used and I think, not sure since I do not use the presets, that it comes this way and caused your problem.
Could be way wrong there but pretty confident your problem is the texture being applied to the transparency.

Take care,

billmi
05-20-2008, 07:30 AM
Nope.

I know what you mean re: the transparency layer, and it is on for the input objects, and needs to be turned off, otherwise, they'll key with the default silouhette shape. This is different though, it's the FX source, and it's keying instead of scaling.

Thanks, though.

joseburgos
05-20-2008, 09:17 AM
Just to be sure here that we are saying the same thing, under the basic tab of the surface, the transparency "T" button is not white because it has no texture assigned?

billmi
06-26-2008, 11:37 AM
No, for the FX layer the T button is not white.
For the Input layer it is on - but within the texture controls the bitmap alpha layer is unchecked, and the video surface alpha layer is checked (so it will use alpha based on the LiveMatte keyer.)

As to my problem - that the video was not scaling for the FX layer, after coming back to this on and off since I originally posted, re-downloading the LiveSet generator to test with original objects and surfaces, and futzing some more - I realized the problem was right in front of my face. The reason it was keyhole mapping the FX channel is because I told it to!

In the live set generator window, there is a column of controls labeled "include cameras" that select which camera is used for each of the four views. The next column is labeled "Keyhole Matte" and is check boxes for whether or not to keyhole matte (show as a cut-out, rather than scale the video) the Input camera view for each of the four views. The next column is unlabeled (or at least that's how I interpreted it) and consists of check boxes labeled "FX."

So, I had been checking the FX boxes, to activate the FX channel in the render, much as one would select the channels used when creating a LiveSet in Aura.

That's not it at all. The FX boxes are also selecting whether to keyhole matte,channel. I told LW to make it keyhole matte, and it did.

:-P

joseburgos
06-26-2008, 04:00 PM
Ahhhh...
Hey Bill here is a tip or better phrased a watch out for.
Do not use the check box for Keyhole Matte for the input on anything other than a closeup of just the actor (video frame full screen).
Besides not scaling, it does not reflect properly on surfaces when it is checked.
I learned this when trying to create a closeup with geometry still in the frame.

Anyway, glad you worked it out.
Take care,