PDA

View Full Version : Frustrating!



akstylish
05-10-2008, 05:03 PM
So I began learning LW again yesterday. I was following rigging tutorials for about an hour, and I accidentally pressed r or something and it rotated my character. No big deal, I pressed ctrl+z, but then it messed up the bones instead. Something like this has happened a few times before.... It seems like undo doesn't work on some functions? It's my fault that I don't save often, but it's so annoying. :(

pumeco
05-11-2008, 03:38 PM
Bad luck on the screw-up, but regards the undo in LightWave, I noticed it's not at all like other programs' undo. LightWave tends to break an undo into the component steps that was used to create the task you're wanting to undo - if that makes any sense.

Like when you create a shape and then decide you want to undo it, you would probably have to hit undo a few times before the complete undo is done. It's weird I know, annoying, but I think it is a trait that maybe flushed out as NewTek continue to rewrite the old 'behind the scenes' code.

akstylish
05-12-2008, 04:02 PM
So...is it something that needs to be fixed?

akademus
05-13-2008, 01:11 PM
That is a problem coming from a long time ago. Workaround for this is:
1. Set the keyframe for all items on minus some frame. To do this, hit Enter key, type -10 for Create Key At, select All items in For menu and make sure all channels are selected.
2. When you mess stuff by pressing r, delete all keyframes at that frame, go to your -10 pose and create keys from there to your messed frame. This will restore the pose to initial one.

Hope this helps.