PDA

View Full Version : Hypervoxels not working when my camera is too close



Jeniene
05-08-2008, 12:37 PM
Hi!

My hypervoxels aren't showing up in my render when my camera is too close to them. How do I fix this problem?

(I'm trying to get a smoke trail come off a weapon as it is being fired from a fighter plane. The trail shows up in layout, but when I render, the trails only start appearing when they get a certain distance away from the camera. I tried moving my camera farther away and zooming in, and it works, but I don't want to have to use that workaround as it causes other problems for my scene.)

Thanks,
Jeniene

Phil
05-08-2008, 12:47 PM
Check the clipping distance - shading/advanced tab in the HV panel.

Jeniene
05-08-2008, 01:22 PM
I changed the hypervoxels from a srpite to a volume and set the near clip distance to 0m, 100mm, and 1mm, but that didn't change anything. It still only rendered at some pre-set distance from the camera. I'd also like to keep them as sprites since they render faster.

Any other suggestions?

Mr Rid
05-08-2008, 03:20 PM
First, what version of LW are you using, and is it Mac or PC. HVs do normally render even when the camera is right in the middle of one. There were problems with this in older versions of LW. And you are certain you dont have a gradient somewhere set to Distance to Camera?

When a scene is doing something odd, I always reduce it to its simplest components and the problem shows up. Try a new scene with only a null with a volumetric voxel on it and see if it renders close to cam.

Jeniene
05-08-2008, 04:27 PM
Thanks!

It turned out to be that the "Fixed Near Clip Distance" option in the Volumetrics tab in Effects was unchecked. I checked it and then set the distance to a small number (1mm). I had figured that with it unchecked it would not clip at all, but apparently that is not the case.

bgolden
12-04-2009, 10:17 AM
Had same issue. Drove me crazy. Thanks for answer. What would this be used for?