PDA

View Full Version : Newbie requesting help: Surface Baker and Render Threads



MariaChristina.
05-07-2008, 08:04 AM
I'm a complete newbie to LW (in fact, I just installed v9.3.1 today! Yay!) and I've gotten stuck on surface baker and render threads.

I'm trying to bake some nice 3D clothes textures for Second Life and I'm following a tutorial on the subject (http://www.nafii.com/PixelDolls/?p=87) -- unfortunately, the writer no longer supports the comments, hence why I turn to you guys.

When I come to do my first render (F9) I get an error message that says:

"Surface Baker does not work with multi-threaded rendering. Please set number of render threads to 1.

In the tutorial 2 render threads are generated. Now, I have not the slightest clue as to what to do.... Is there anyone who can help?

Let me know if more info is needed.
Thank you!

manholoz
05-07-2008, 08:18 AM
You should use the camera bake, not surface bake, as it is multithreaded.

MariaChristina.
05-07-2008, 09:36 AM
Thank you manholoz!
I actually ended up fixing the problem by setting Multithreading to 1 Thread under Render Globals -- I hope that's an acceptable fix! :))

manholoz
05-09-2008, 04:16 PM
It is good to know you got that working.
But you should really look into the baking camera, it has more features.

amyhughes
05-19-2008, 05:13 PM
Can you please explain exactly what you mean by using the baking camera rather than the surface baker? I tried changing the camera type to baking camera and eliminating the surface baker renderer but

1) I still got the number of threads error
2) the program crashed when the render started

I found this thread researching another problem I'm having with the surface baker, which I'll post separately.

Thanks,
Amy

amyhughes
05-19-2008, 06:28 PM
Oops, nevermind. I found a surface that still had the surface baker renderer checked.