PDA

View Full Version : “Weird” smoothing in modeler



VoodooChile
05-02-2008, 08:03 PM
Hi,

I’m new to Lightwave and I’ve been reading the book “Essential Lightwave v9” by Warner/Phillips/Albee. While working through a video tutorial that accompanies the book, I encountered some strange smoothing after beveling one of the polygons in my object. I have attached an image that demonstrates the problem. The selected poly is the one that was beveled. The object was smoothed by clicking the Smooth button for the Default surface.

Steve Warner talks about these smoothing errors in the video, but he doesn’t really explain why they happen. He recommends cutting and pasting the incorrectly smoothed poly to fix the problem. I have tried this and it does work, but this solution “detaches” the poly and duplicates its points. If I use the Merge Points tool after cutting and pasting, the duplicated points are eliminated, but the smoothing error returns.

I verified (using Statistics panel) that there are not any non-planar polys or points that aren't part of at least on poly.

Is this behavior just an OGL display glitch in Modeler? Is there a better way to correct the issue than cutting and pasting (which duplicates points)? If I don’t correct the problem in modeler will this cause issues in Layout when I try to surface/render the object?

Thanks

hrgiger
05-02-2008, 08:10 PM
Try reducing the smoothing angle for that surface in the surface editor.

Matt
05-02-2008, 08:15 PM
LightWave (currently) smooths objects with one setting, in certain circumstances (such as in your model) it can be difficult to find a setting that works for all areas of the model. The default of around 89 degrees is often too high, I found that for more geometric models a value of 40 degrees works quite well.

The other way to remove the smoothing issue you see on your model is to create a 'buffer' edge between the flat areas and the radius. To do this select the top flat polygon and use the 'Bevel' tool with the 'Shift' value set to 0 and the 'Inset' value to something very small, just enough to correct the smoothing error.

Matt

VoodooChile
05-02-2008, 08:48 PM
Success! First I tried the recommendation to reduce the smoothing threshold, but it didn't quite work on this particular model...I had to reduce the angle so low to get the top poly corrected that the facets started to show through in other areas of the model.

Then I tried Matt's suggestion to create a "buffer" edge with the Bevel Tool and it worked like a champ.

Thanks for the help :thumbsup:

clagman
05-13-2008, 02:43 PM
There is always the cut/paste quick fix if you don't mind sharp edges.