PDA

View Full Version : I'm going crazy, DOF is killing me



Philipp
07-22-2003, 03:54 PM
Please help.....

I think I tried every combination but it just won't work. What I want to do is to render two images, one for the rgba and one for z-depth. The z-depth is donne using the surface settings Gradient Distance to Camera. Ok, I rendered both images, tried it with LW and Cinema just to be sure and the images are fine.But it doesn't work, I simply cannot have both layers combined so that I have the rgba as foreground and the-z buffer for the DOF. I'm relly getting insane here, PLEASE, somebody help.....it can't be so difficult or can it be???

Justinw
07-23-2003, 07:03 AM
Hi there,

Are you rendering out the Z-buffer as an image? The Z-buffer is actually a set of values which tells each pixel were it is on the Z-axis. It looks like an image when viewed, but its not, so a normal grayscale image will not work. Have you tried exporting out a RLA or RPF file (allows you to include the correct Z-buffer data within the file). Render out your scene with RLA or RPF export in the Image process queue, (double click the export to bring up its settings). Render your scene, and load up the RLA (or RPF) file into DFX+ (or Digital Fusion, whatever you are using). Apply the DOF depth tool and play. Works a treat.

Cheers,

Justin W.

Philipp
07-23-2003, 03:29 PM
Hi Justinw,

I rendered both ways, as RLA and RPF, but the z-channel had no depth, I mean the object was only one grey with no gradient, so I tried the distance to camera surface atrribute which normally works fine.

I started a thread at cgtalk too, Jayk2k, could help me a little bit.
http://www.cgtalk.com/showthread.php?s=&threadid=77380

I'lle have to give RLA/RPF another try.