PDA

View Full Version : Hypervoxel Shadow Problem



bobakabob
04-26-2008, 06:35 PM
Messing with a space scene I'm having problems with hypervoxels. I've created a starfield of points with hypervoxels applied as a backdrop.

Weirdly in sprite mode the hypervoxels are receiving shadows when the main light source is an area light set to raytrace (see first pic). This spoils the illusion of depth. I've turned off volumetric lighting and unchecked 'self shadow', 'cast shadow' and 'receive shadow' in object properties but the shadows - big black blotches in the first pic - are still there. How can I lose them?

When the light is set to 'spotlight' with 'shadowmap' applied (second pic) the shadows disappear but the renders predictably aren't as good. Can anyone help?

Surrealist.
04-26-2008, 07:22 PM
Sprite mode is the problem I am almost certain.

Short thread (http://www.newtek.com/forums/showthread.php?t=82612&highlight=Sprite) on it.

bobakabob
04-27-2008, 04:06 AM
Sprite mode is the problem I am almost certain.

Short thread (http://www.newtek.com/forums/showthread.php?t=82612&highlight=Sprite) on it.

Surrealist, thanks, I've checked out the previous discussion... Aren't sprites meant to be shadow free? If so, is this a bug... there should be a way to switch them off...

Surrealist.
04-27-2008, 08:34 AM
I don't know. It may be. But I have never considered sprites to be anything but the Viper of volumetric effects. Sure you can use them for many things but in complex scenes you will see problems. You get a similar problem with sprite mode in volumetric lights. Is this a bug or are they just not designed to be anything other than a quick way to get a feel for what things are going to look like with a volume object? The latter is the way I remember being introduced to them. Maybe I am wrong on that. But I think this is why they have problems with shadows.

bobakabob
04-27-2008, 05:48 PM
Yep volume mode seems to gives more flexibilty.

Hope Newtek can fix this though... I've sometimes had better results with sprites than volume in creating whispy fire effects... they can have a unique look all of their own.

prometheus
04-27-2008, 08:56 PM
I believe you have the hypervoxel sprites set to more than one slice, if so they will pick up the shadows from the area light.
the different slices options are there to give a more volumetric feel but since itsīnot really volumetric only slices, you canīt turn shadows of as in real volumetric mode, would be nice if we could perhaps.

if you set it to on slice only they should be gone, of course you might loose in volumetric feel on the voxels..you have to try out.
Otherwise I would suggest that you render out in different passes.
and mix it in comp afterwards if you can.

Michael