PDA

View Full Version : Glass problems...



MSwengel
04-25-2008, 08:39 AM
I followed William's tutorial (here: http://www.newtek.com/forums/showthread.php?t=78198) to the letter, but I just can't seem to get a good glass effect. Here's what I came up with after following his lead....

*big image alert*
http://img131.imageshack.us/img131/8867/picture2fm6.png

This doesn't look much like glass at all. I do have all the important ray trace options enabled.

I've also tried playing around with Absorption and RI - without much luck. What could I be missing?

Any suggestions? :help:

Thanks,
MS

JeffrySG
04-25-2008, 09:23 AM
You have reflection and refraction enabled? just checking...

MSwengel
04-25-2008, 09:33 AM
Correct. Both are enabled.

RudySchneider
04-25-2008, 10:03 AM
Don't forget that there are separate Render Global as well as Camera Properties. If you're simply changing the Global Properties, but haven't checked "Use Global" in the Camera Properties dialog box, you'll be disappointed.

MSwengel
04-25-2008, 10:45 AM
Sadly, that didn't help it. Although I don't know why. :bangwall:

DAMAKERS
04-25-2008, 11:09 AM
have u turn on the nodes in the surface pannel?

also could u put something to be refletcted so can see the glass behavior.

maybe u know all this, but trying to help :thumbsup:

JeffrySG
04-25-2008, 02:43 PM
The easiest thing is to probably zip up your model and scene and post it here so we can take a look....

MSwengel
04-25-2008, 07:25 PM
Alright. Here are my files, LWS and LWO.

Messing with Absorption has some weird effects. If I set it to 1.0 or higher, the glass is invisible.

Also, the "glass" material is named "Cup" in my scene.

This was done on an Intel Macbook Pro with LW 9.3.1 Mac32.

Thanks for any suggestions, guys. I do appreciate it.

MS

RudySchneider
04-25-2008, 09:15 PM
You've got a couple things going on here, MSwengel...

1. Your object is HUGE! When you model, try to scale your objects to real-world dimensions. The primary reason for this is that the lighting and camera in Layout are based on real-world optics.
2. Your glass is quite thick. Hence, it will naturally absorb more light.
3. Try not to use 100% diffuse settings for your materials. something on the order of 60-to-70% is more realistic. Learn to rely more on your lighting (which I also bumped up to 100% for BOTH lights) to set the mood..

I did a quick reduce of your model to 9% of what was, repositioned the camera, and here's a simple render:

RudySchneider
04-25-2008, 09:38 PM
BTW, I set the absorbtion to 20 (percent), and th refractive index to 1.5.

MSwengel
04-25-2008, 09:42 PM
Ahhhh! Now that makes sense. It was absorbing too much light because of its size - in layman's terms. Thanks!

MSwengel
04-25-2008, 10:48 PM
BTW, I set the absorbtion to 20 (percent), and th refractive index to 1.5.

Could you post your scene file? I resized the object (in Layout) and readjusted the camera and values - without much luck.

I've attached the altered file. It's "resized.lws."

RudySchneider
04-26-2008, 12:03 AM
I didn't resize the objects is Layout. I resized them in Modeler, where it's supposed to be re-sized. I didn't save the Layout file, but here's the Object file. BTW, I also centered everything, and placed your backdrop on the X-Z plane, just out of habit.

MSwengel
04-26-2008, 12:13 AM
Aha! I see! Thank you, RudySchneider!

Note to self: resize in Modeler... :)

Thanks again,
MS