View Full Version : Lightwave crashes to desktop (CTD) when a file dialogue is open and during renders

03-28-2008, 11:50 AM
There were a couple of other threads on this (actually only two specific ones) but none of them helped me enough.

Well, LW crashes to desktop. No error messages, no reports, not even a memory dump... It started doing this after the network at my office went down a couple of times, taking my machine down along itself. Had to hard restart my machine a couple of times and everything was back to normal after the network recovered. Except LW...

List of symptoms:

Sometimes; when you start a render with F9 LW Crashes to Desktop.
Sometimes; if it finishes the render, just before the image viewer appears LW Crashes to Desktop.
Sometimes; if the render is finished and the image viewer comes up, LW Crashes to Desktop just as I try to save the image.
Sometimes; when the file dialogue is open and I'm just locating some folder LW Crashes to Desktop.

By 'sometimes' I mean "each time I launch LW some kind of crash happens for sure but the way it occurs changes" kind of sometimes. I just cannot work.

Among the few times I actually got an error message before the crash I got some memory addressing problem reports. Checked the RAM through memory exclusive tests and they were OK. I'm guessing some Windows .dll went bad and it's causing the lw9tools.dll memory addressing issues. Someone in the forum commented it was all about shell extensions and you can manage this by temporarily turning off the shell extensions while LW is on. Didn't work. Some other guy posted about some problems with the network config and that his IT guy at the office fixed this... but, the post was not detailed on how he did it. I'm guessing it really could be about some .dll's concerning the network operation and Windows kernel.

I also checked my registry. Didn't work. I cleaned up the LW pref files. Didn't work. Turned off the Hub. Didn't work. Uninstalled/Cleaned the Registry of LW Related Keys/Reinstalled Lightwave. Didn't work. Updated graphics drivers, windows, etc. Didn't work.
And only Lightwave does not work. There is nothing else going wrong with anything else on my machine. And I don't want to lose a perfectly functioning system and format the system just for this.

Help! Please! I also think this will save more than a couple of people's misery when someone comes up with a proper idea on how to fix this. It seems a lot of people suffer similar problems.

Thanks in advance,

04-09-2008, 02:24 AM
Hi again... I finally had to format my machine last week. Set everything up from scratch. Perfect! Lightwave was back to normal. For a week... Than, today, it went back to the exact same state that finally ticked me into formatting it.

It started again while I was doing some extensive work in AfterEffects. I am so upset... SO UPSET...

LW just crashes to desktop when you try to open a file dialog after an F9 render or just when you click 'save' or when you try to load a file...

No one replied to my post; I still have the problem, I still need the help, so I figured I could post those other threads I've run into on similar cases so maybe someone can remember about something to help.

Here are the threads that were relatively more related to what I'm probably suffering.




By the way, it may really be about the shell extensions or some conflict with the shell as one of the guys in these posts says but his solution didn't work (disabling the shell extensions temporarily). Still, it may be closer to the solution than other things, what else can I do to diagnose and maybe repair a possible shell extension issue?



04-09-2008, 02:41 AM
Just noticed this...

There is one more symptom: .lws and .lwo files also lost their association with LW but their icons remain unchanged. You can only open them through launching LW first.

04-09-2008, 03:29 AM
Well, welcome to the LightWave community.

One thing you might take a look at is a hardware issue. An overheating CPU or a RAM issue. CPU will usually turn off the machine, so that is probably not it. But RAM will shut down LW in exactly the ways you are talking about.

You reformatted, started from scratch. At this point I would start looking at hardware problems.


Did you at the same time start trying to work on a larger scene?

This would point to RAM.

04-09-2008, 04:00 AM
Firstly, thank you for replying. I was beginning to feel desperate and that no one likes me.

: )

Actually I have been part of the Lightwave community for some years now but I lost my old account and got this one. I used to have the account name Cheshire Madcat.

Anyway, I had also suspected RAM but I already ran a dedicated RAM test I downloaded from Microsoft for a couple of passes and it didn't show any problems. I also switched RAM units in their slots recently to check if anything is behaving differently. Nothing new.

And my scene consists of one simple object + 2 spots + 1 area light with no special effects, no particles, etc.

Also, my machine doesn't cause any problems with other software installed. And it used to be problem free with Lightwave as well, for months. I don't know why but after some point, it started not liking LW. Even after a fresh install this continues.

Any other ideas?

04-09-2008, 04:09 AM
Graphics card, or any other hardware issues. I can't think of why after a fresh install it would do the same thing. LW above all other programs is much more CPU and graphics card intensive - or sensitive in the case of the graphics card. I can't think of anything else at the moment. Other than something to do with your networking set up that may have changed after the crash. That may effect the Hub.

04-09-2008, 04:23 AM
Graphics card drivers, mainboard .INFs, Wacom tablet drivers, Windows Update... Nada...

As you mentioned, it may also have something to do with the network setup. Someone else mentioned a network problem causing this, in one of the similar threads. But he couldn't tell what the IT guy did to solve it.

04-09-2008, 05:46 AM
OK, then....well, sorry I was not able to help. Maybe someone will come along who knows about networks.

04-13-2008, 08:03 PM
I'm having possibly the same or similar problem on 9.3
I'll try installing 9.3.1 and let you know how that works out.
Bugs are ruining my chances at making money at the moment. Had to say no to a client because well, basically I can't render right now.

04-18-2008, 09:13 AM
Found it!

Reinstalled... Did the setup step by step and took whole drive images with Acronis in case I wanted to roll back. Everything went fine until we installed the Norton End Point Client through the network.

Norton does it. The error was repeatable, we confirmed it with the IT chief at my office. Symantec Endpoint Protection probably designates any LW related file system actions as threats (saving, opening, allocating virtual memory, intense memory activity...). Now I remember it... the symptoms appearing after a network-wide update of the Norton Clients. It just doesn't notify you when it is updated so you don't get suspicious. It was also causing the same errors even when we disabled it temporarily. Symptoms only disappeared when we uninstalled the client.

It seems there is currently no work around. Our IT chief was hopeful that the recent update could solve it. It is still the same for now. I've unfortunately been running my machine without Norton. If it is not solved soon I'll have to use some other anti-virus software.

Hope this helps.