PDA

View Full Version : Normal Map Frustations



Ramen Sama
03-24-2008, 05:11 AM
So i've been messing with this for about 12 hours or so now i'd say.... and i'm pretty much at my limit. I've been working on creating a normal map for experimenation in a game engine. spent about 8 hours in total confusion as to why the hell the normal map didn't work properly.

I'm using plugins located
http://amber.rc.arizona.edu/lw/normalmaps.html
which i believe are the only plugins lightwave has for creating normal maps.

Is anyone here familiar with using these plugins?

http://subvoicestudios.com/~ramensama/base.jpg
Low Poly object.

http://subvoicestudios.com/~ramensama/close.jpg
This is close to working.. this is using the TB Normal Map Shader

http://subvoicestudios.com/~ramensama/notclose.jpg
This is with lightwaves node editor. it's very similar to the results i get in the game engine.


http://subvoicestudios.com/~ramensama/uvmapped.jpg

And here's a shot of the UV

dpont
03-24-2008, 05:38 AM
Your normal map is in world space,
so TB shader works well, but LW Normal node
uses tangent space normal map,
but you have also this option in NormalMapCreate
Modeler plugin.
There's also another way to get tangent map
with a (DP Kit) Normal Cast node and Surface Bake Camera
in Layout.

Denis.

SplineGod
03-24-2008, 12:11 PM
I would also highly recommend this:
http://www.3d-coat.com/

RollerJesus
03-24-2008, 12:21 PM
Hey Ramen, I'm working on getting some models into TGEA as well... (You've helped me on the GG forum a few times)

I plan on testing some things tonight and I will follow up here with you.

Patrick

Ramen Sama
03-25-2008, 12:15 AM
Well changing to tangent definately did the trick there. Now i just need to figure out why it's creating ugly seams. I've got a nice texture baked image that has no seams. Guess i'll mess with the UV map and remove any curves on the outsides of the UV Islands.

Ramen Sama
03-25-2008, 04:53 AM
Ugh, this DP Kit doesn't work well at all. Nothing i adjusted in the distance settings would work. I kept getting "artifacts"

I'm used to using surface baker, but i have no clue what i need to set the setting in the projection settings to get it to work right.

http://subvoicestudios.com/~ramensama/normalartifacts.jpg

RollerJesus
03-25-2008, 06:42 AM
Are you using the surface baker or the surface baking camera?

Ramen Sama
03-25-2008, 04:14 PM
Surface baking camera, per instructions of the plugin.

Ramen Sama
03-29-2008, 04:17 PM
I tried using the plugin Normal Map Color, for layout, combined with surface baking camera and it produces perfect world space maps.... no seams of any kind. So i'm going to mess with this some more and see what happens. Course, i'll need to figure out how to convert it to tangent.

Ramen Sama
05-22-2008, 11:46 AM
*Bump*

Would still like some help if anyone might have it.