PDA

View Full Version : HDRI/Shadow Density Alpha Problem



WesM
07-18-2003, 06:24 AM
Hi,
I'm having a problem using base alpha from Shadow density for an object, when I use radiosity and HDRI. I am compositing a car on a live action plate. I made a street plane to cast my shadow of the car. I used front projection mapping to match the ground object to the background image. I am lighting the scene with an HDRI and radiosity. I want to render the scene, and have the car and car's shadow in the alpha, for later compositing. For the ground plane, I turned on base alpha from Shadow density in the surface editor. When I check my alpha I get the car, but no shadow, although there is a great shadow in the scene cast from the car.
I dont know why the shadow is not showing in alpha. I have used this option before with no problems. The only thing different is the HDR and Radiosity. Can base alpha from shadow density not be used with HDR and Radiosity? I would greatly appreciate anyones advice.

Thanks,
Wes

Lightwolf
07-18-2003, 06:38 AM
Originally posted by WesM
Can base alpha from shadow density not be used with HDR and Radiosity?
Unfortunately it can't, no.
You could render a seconds pass, making everything except the ground unseen by camera, and replacing the ground plane with a 100% diffuse white plane that you can later on composite over (or under in your case).
It won't be 100% perfect, but it will work.

Cheers,
Mike

WesM
07-18-2003, 08:15 AM
Thanks for the help Mike.

I was afraid it wasn't working because of the radiosity.

I will try your technique. I am not good with multipass rendering. I have done so many tutorials on it. I haven't been able to pull it off though.

Thanks,

Wes