PDA

View Full Version : buttons for Lscripts (mac)



quatermain
07-17-2003, 10:08 PM
I am trying to assign buttons to Lscripts (thickener and polysew), but whenever i restart Modeler, these buttons disappear - see the picture below. Adding plug-ins works fine. I'm adding the Lscripts as plug-ins and then adding them to the interface. Am I doing something wrong ?

BeeVee
07-18-2003, 02:08 AM
How are you quitting Modeler? The menu configs get written to disk when you leave the application...

B

riki
07-18-2003, 03:18 AM
Make sure after you make changes that you save your custom file configuration with the .cfg extension and then quit out of the APP before you go any further.

faulknermano
07-18-2003, 04:41 AM
make sure, just in case, that you are running only one lw app at a time. that means if modeler is open, close layout before close modeler. layout rewrites the lwext3.cfg file because both apps share that file.

gjjackson
07-18-2003, 06:00 AM
It seems; I've found I've had to actually 'Use' the plugin before it's included in the cfg.

quatermain
07-18-2003, 08:35 AM
ahh, yes, just using the Lscript saves it after quitting.

where do i save the .cfg file on a mac ?
i recent acquired my 1st pc. will copying this file to the pc keep the custom interface and hotkeys ?

thanks

BeeVee
07-18-2003, 08:39 AM
On the Mac they are pref files and while the names are different, the contents are the same, so yes, you will be able to transfer them over...

B

riki
07-18-2003, 09:16 AM
On the Mac (OS9) you can just save them where-ever you want. Not sure about OSX??

toby
07-18-2003, 04:48 PM
In OSX find them at:
Users/YourName/Library/Preferences/Lightwave Modeler 3 Prefs

quatermain
07-18-2003, 05:15 PM
ah, cool. i thought they were the ones in the Lightwave>Backup Configs. I will give it a try
danke