PDA

View Full Version : Smoothing Problem



Aqueous
03-08-2008, 04:56 PM
Hello...

I apologize if this post is in the wrong place. And I'm sure this problem has already been answered somewhere, but my searches have yielded no help. And I know I've solved this problem before, but I don't use LW often enough to remember what I did.

I am using LW 8.

I created these objects by importing an Illustrator file (it is part of a corporate logo) and extruding.

In the surfacing panel, I have smoothing enabled with a threshold of 89.53.

The "edge" polygons are smoothed, but you can still see the "sides" of the polygon that makes up the "face" of the oval objects.

What do I need to make those oval faces smooth around the edge (so that you can't see the points)??

Keep in mind, I do not want to "dome" the face, just make the edges appear to be a smooth curve.

Any help would be greatly appreciated!

Thanks!

R.Feeney
03-08-2008, 05:01 PM
You need to turn on smoothing for the surface in the surface editor. you may need to adjust the smoothing treshold if the tops and sides share the same surface

Aqueous
03-08-2008, 05:11 PM
Hi R.Feeney!

Thanks! But unfortunately, I've tried that. But when I do, it rounds the tops of the objects so they look like watermelon seeds instead of the tops remaining planar surfaces with smooth, curved edges.

See how the yellow objects are rounded on top now? I don't want that.

Any other thoughts? Could it be an import issue?

Lightwolf
03-08-2008, 05:17 PM
Wow, these look strange even in the first image. Are you sure that the tops are perfectly flat? If not, smoothing will make them... smooth.

And angle between 15 - 30 should be all you need to get the sides smooth.
If that fails, on modeler select them top polygons, cut and then paste them (don't merge points after this). However, if the top isn't flat to begin with that won't help either.

Cheers,
Mike

Aqueous
03-08-2008, 05:26 PM
Hi Lighwolf,

The tops are, unfortunately, flat (or rather, they have no reason not to be).

I've eliminated the shadows and reflections to hopefully make the images clearer.

You can see that the side polygons are smooth where they meet each other, but where they meet the top and bottom polygons, the points and sides are visible.

In the image with the gray polygon top, that polygon was cut and pasted into a new layer and smoothing was set to 91 degrees. No help.

What to do?

R.Feeney
03-08-2008, 05:37 PM
Thats where the smoothing treshold comes into play, it sets the maximum angle between polygons that it will try to smooth between.
As Lightwolf says though the tops do look a little odd, like they dont quite lay flat.
You have a number of options
1. give the tops of the cylinders a seperate surface to prevent the smoothing crossing over
2. Cut and paste like Lightwolf said
3. select the tops of the cylinders in modeler and use set value to flatten them and use the smoothing treshold to control what gets smoothed.

if none of this helps perhapse post a wireframe so we can see whats going on in the model

arsad
03-08-2008, 05:39 PM
the top polys still look weird. not flat at all!

For your problem with the poly edges visible (not smooth at the top)
Try to use fine or superfine in the eps importer.
This will give you more points on the sides and smooth things out.

how did you extrude your object? The top polys really look weird!

dwburman
03-08-2008, 05:40 PM
you need to add more geometry to smooth around the edges.

here are a couple of quick ways

1) hit 'w' to bring up the statistics panel...
2) make sure you're in polygon selection mode.
3) hit the '+' next to '4 Vertices' - this selects all the quads, which are the sides.
4) hit 'Shift-D' to subdivide polygons. click the 'smooth' button and then 'OK'
5) repeat step 4 until you're happy with the level of smoothness... depends on how close the camera is going to be to the camera

The down side to that technique is that you end up with a lot of extra geometry.

another technique is
1) 'w' to open the statistics panel.
2) click the '+' next to '>4 Vertices' - this selects the tops and bottoms.
3) press 'e' to run 'extender plus' - this creates extra geometry... but you won't see it because it's in the same place.
4) in the 'multiply' tab, in the 'Subdivide>More>Make Pole' - this breaks up the circles into smaller bits of geometry
5) deselect anything you have selected
6) press 'tab' to turn the object into a Sub-Division object. The top edges are a bit rounded but not as much as before.

Aqueous
03-08-2008, 05:46 PM
Here's the wireframe.

R.Feeney
03-08-2008, 06:37 PM
I have a simple model attached that you could clone to replace the cylinders in your model.
I think I was misreading your problem, was it the silhouette edge you wanted smooth rather than the sides.

rakker16mm
03-08-2008, 10:17 PM
I'm not sure this will help and you may have already tride it, but it may get the effect you are after.

Before importing the Illustrator file into modeler, hit "O" for general options and next to Curve Divisions choose "Fine".

Any way I hope that helps.

j

PS: I see some one else already suggested it. :)

Cohen
03-09-2008, 12:04 AM
Traditionally shading errors were fixed by adding a little more geometry. Normally it would just be a tiny bevel on the poly that isnt rendering correctly. If none of the pervious suggestions worked in your scene (which would be odd), then try this.

Assuming the top polygons of those cylinders are not flat, try to fix the shading by subdividing your geometry using Catmul Clark subdivisional surfaces. Then crease the edges of your C/C subd's around those 2 rings. That should give a refined tesselation come render time, and should give you correct shading.

Aqueous
03-10-2008, 11:03 AM
Thanks for all your help, everyone. I appreciate it.

I eventually just re-imported the EPS and started from scratch. I didn't change anything, but it worked. I don't know what I did the first time that made it foul up???

Oh well... onward.

Thanks again!