View Full Version : How to limit a position channel??? anyone?

03-08-2008, 08:07 AM
I want to limit the Z position of an object. How do I do that?

03-08-2008, 08:59 AM
There may be a simpler way, but you could create a null, and tie the z position of the object to the z position of the null through an expression using clamp. Apply this expression to the z channel of the object you want to limit:


where Null is the control null, and 0.000 and 2.000 are the lower and higher limits you want to constrict the object to.


03-08-2008, 09:14 AM
You can use sliders for that.

03-08-2008, 09:46 AM
Thnx Eric, that works... really really strange that theres no standard function for limiting position channels, it's a little prehistoric!

03-08-2008, 09:49 AM
I saw a plugin named "channel limiter" on flay but the link is dead :(

03-08-2008, 10:08 AM
Just wanted to share in case someone else needs it.


Still not really what i was looking for, but its close. Now if it exeeds the limits it pops back in place.

03-08-2008, 03:58 PM
I guess Dpont's "Node Item Motion" and a clamp node will also work.

Jim M
03-08-2008, 04:10 PM
Or Ikbooster for simple n quick

03-08-2008, 06:12 PM
Or wait for 9.5 ...


03-08-2008, 07:06 PM
When coders come out of hiding, things are getting closer...

I would have used Relativity as one of my choices, in order to stay on topic.

03-09-2008, 05:37 AM
Or Ikbooster for simple n quick

Yes, can be done easily with IKBooster.

03-09-2008, 08:43 AM
thanks guys!!! going to try ikbooster!....

03-09-2008, 09:40 AM
okay?!?! Ik booster... I've played with it for some time now, but i can't find an option where I can limit the position channels!?! And I don't know how to use expresions that good so relativity is not the most easy option.....

03-09-2008, 01:36 PM
Finaly I got my limits set. I connected the (limited) rotation from a Null to the Position.Z of the object I wanted to limit. No strage jumping effects. The only thing is that I know need to rotate an object that I want to move. But I can live with that.

03-10-2008, 04:08 AM
With IKBooster, You must set the node to "move" - that's a red box around the pivot, if it isn't allready (If Your Object is a single object, it's single node should be in move-mode by default; if it's a child of another Object, it will be in rotate-mode).

So the steps are:

1) activate IKBooster by clicking the button in the modify tab or pressing ctrl-b

2) Right-click on the pivot of the Object and "apply IKBooster".

3) If necessary, right-click on the node, and set mode to "move"

4) Now, when right-clicking on the small x / y / z - Letters beside the red box, You'll find a menu to limit the movement.

03-10-2008, 05:14 AM
thnx Dirk. I got it working....:)