View Full Version : Dognle issue - help please

03-07-2008, 08:40 AM
i've a 32bit LW, i've installed it on a 64 bit system.
There's NO way i can make it see the dongle, which is fine on other machines.
I removed-reinstalled several versions of the driver, i even used cleaners from Safenet to clean system, but still no go.
When i plug it in, i see it among peripherals but it's not seen by LW.
Can someone tell me all things i should look at ?


03-07-2008, 09:00 AM
Hey, I recently upgraded to Vista 64 and had the same problem. I had to download the latest Sentinel drivers from their website, then reboot.

Login to register.newtek.com, and get a new key for LW 64 bit. Then run the registration utility.

Reboot again, and it worked fine.

03-07-2008, 09:23 AM
When you opened LightWave did you get a license error? If you did, and the dongle was detected, you should then see a product lock ID listed in the license error window.

Your not going to have the same license key for XP 64 as you did for XP 32. You have to register with your new Product Lock ID (AKA: dongle ID).

03-07-2008, 09:24 AM
Ciao Paolo,

Are you sure you installed the 32-bit version of LightWave? Did you try installing the 64-bit version too and seeing if that works? If you have come from a 32-bit version you will need to re-register to get a 64-bit license.key:

1. Login to the Registration system at http://register.newtek.com;
2. Go to My Products;
3. Copy the LightWave v9 serial number from there;
4. Go back to My Home and register a new LightWave 3D;
5. Paste the serial number you copied and you will be presented with a page where the licence you already registered is filled in, but there are empty cases for the other two platforms. Make sure you verify that the dongle number is correct for the platform you are registering.


03-07-2008, 01:37 PM
RollerJesus, thanks gonna try...
Sntorres - no error, it just starts in discovery mode. but it's enough to know i've to re-register it for 64, i didnt think so.
BeeVee, absolutely sure, it's a 32 bit one. Problem is that i cant see dongle number anywhere into LW, it's like it cant see it at all, but system does.
I opened two threads (i apologize), but maybe we can unify them and jump here:


thanks all

03-09-2008, 01:29 PM
Hi all, in case you didnt look at other thread, i posted this, maybe it's useful to know:

"Ok, it's official, i did a direct test: Remote Desktop prevents Dongle (on remote PC) from working.
Is this a known limitation or is there something i can do about this ?


03-10-2008, 09:26 AM
There's one I'll add to the FAQ right away.

Yes, Microsoft Remote Desktop will not recognize the dongle when it's on the remote PC because RD will only be looking for the hardware on the end it's being operated from. I believe VNC works the opposite way and does actually work with the dongle plugged in on the client side.

03-10-2008, 09:40 AM
OK, here's an FAQ:


It's at the bottom.

03-10-2008, 10:06 AM
To be sure i tried to keep the dongle on client side, but with RD it's a no way.
So it seems i've to buy VNC, no way to do this free.... ;(