View Full Version : USB dongle and XP 64

03-06-2008, 07:05 PM
i want to run LW32 on a 8-core with XP 64 bit.
I installed safenet's 7.4.0 drivers, in System panel it loks like it's actually seeing it... but Lw runs in discovery. Any hint ?


03-07-2008, 03:24 AM
i know it may suond strange, but i usually resolve this by uninstall the drivers, restart the pc and reinstall the drivers....
I do this nearly every time i've got to reinstall LW.

03-07-2008, 04:32 AM
thanks, i did it but nothing. i even reinstalled LW, nothing.
Ah, register.exe (i know it's not working) tells me "no dongle found".
Dongle is not broken since it works on other machines.


03-07-2008, 05:36 AM
i'm really sorry i can't help you!!
It work's for me every time!
Can you try a diffrent version of the drivers?
Good Luck

(strano parlare inglese con una persona che sai essere italiana :) )

03-07-2008, 06:36 AM
hehe, true.
gonna retry...

03-07-2008, 08:57 AM
Try uninstalling/reinstalling the SafeNet drivers. To avoid a restart don't install the Sentinel Protection Server drivers (we don't use them, just the USB drivers).

The only other reasons a dongle would not be seen would be:
a) Broken dongle (call tech)
b) Your dongle is an older USB one that only works on Mac (usually blue, says Eve3)
c) The dongle is plugged into a USB hub or a bad USB port. The most reliable ports are typically the ones going directly into the motherboard, not the front of the case or an expansion card.

03-07-2008, 11:11 AM
Does the dongle show up in Device Manager? Even with no drivers present, it will show up, but with an X or exclamation mark next to it.

If it does NOT show up, yet the dongle works in other machines, you should consider the possibility of having a bad USB port.

03-07-2008, 01:28 PM
Supportron, dongle is ok on other machines, it's purple and no-mac, and i tried also back usb ports. By now i'm trying on USB post in fron of this dell pc, anyway.
Mattclary - it shows id DM, as USBUltrapro. i also plugged other usb pendrives in same ports and they seem to work.
A tech guy here tells something is strange in Event Viewer, it's like if dongle is seen but server doesnt start and gives an error ID4 - here are some screengrabs.

Two things:
- this Lw 32 license has been registered on XP32, can it be an issue ?
- I'm working on this machine via remote desktop.

PS - i hope for a lan licensing system, or a render-only seat of LW we can freely use to fire rendering directly on other machines.
Kinda a local LWSN with direct control of master plugin class (to allow Fprime and Kray), and Render globals panel. Sometimes is so much better than having to use network management tools...


03-07-2008, 02:05 PM
well, i discovered this: i removed the PC from my LAN and used it directly on its own monitor - LW starts nicely. So problem must be in LAN settings, never happened before.


03-09-2008, 01:29 PM
Ok, it's official, i did a direct test: Remote Desktop prevents Dongle (on remote PC) from working.
Is this a known limitation or is there something i can do about this ?


03-10-2008, 12:11 AM
I'm not sure of what you are trying to do, but are you trying to run LW from several computers that at networked, and trying to use the same dongle through the network?


03-10-2008, 04:23 AM
No... i've installed Lw on a machine which is accessible only via RemoteDesktop (it has not its own monitor and keyboard since it's only a node).
I plugged the dongle in its own USB. LW cant see the dongle this way.
I tried to use that PC directly, installing monitor, mouse ,etc, and LW starts perfectly. So using a PC in a LAN via Remote Desktop prevents Dongle from working. Not good, maybe i should tell Safenet.


03-10-2008, 05:37 AM
So, was the dongle plugged into the server machine or into the client machine?

Can't say I am surprised that this didn't work, either way.

I also like how you failed to mention what you were attempting when you originally posted the problem. I'm sure it never occurred to you that part of the problem was that you were trying to run LW from a remote machine. :rolleyes:


03-14-2008, 05:03 PM
Did you leave the dongle in the computer hosting the LW application, and then tried remoting into it from another computer?


03-14-2008, 06:01 PM
mattclary - i didnt mention it because ididnt really thought it could be an issue, i was more concerned about 64 bit thing ;)
RTSchramm - i tried both, it doesnt work.