View Full Version : ATI, mac on xp and modeler

03-05-2008, 03:10 AM
Modeler seems to be crashing almost every time I view a texture, or switch from UV map window to perspective window. This also happens right after a switch and I press any key, or button.

I am on a mac, leopard, with bootcamp running lightwave 9.3 on xp 32.

What the hell could it be? A driver?

03-05-2008, 04:35 AM
I remember ATI driver issues were popping up, did you get the latest updates? I have a macbook pro with nvidia hardware, and it works fine for me.

03-05-2008, 06:31 AM
But where do I install the drivers on the mac-side? I run windows with bootcamp. thanks I will try the update first.

03-05-2008, 07:14 AM
I'm not positive, but I think new mac video drivers are installed during the automatic software updates from Apple. Maybe try running your 'software update' in the system preferences to see if you're up to date (only update if you're sure you want to and it's safe to). Or you could check on apple's discussion forums to be sure.

03-05-2008, 07:42 AM
Try playing with opengl parameters. MultitextureShaders and streaming works better but far from perfect for me.

03-07-2008, 07:19 AM
But where do I install the drivers on the mac-side? I run windows with bootcamp. thanks I will try the update first.

Its easy:) Click the apple icon on the upper left and click on software update. It will give you a list of all the programs it can update. However, you might need to do it more than once as some programs needs to be installed first before you can install another set. At least that is what happened with the updated OpenGL graphic library for me.

Sorry, I have leopard, not sure how that is done in tiger.

03-07-2008, 09:39 AM
The initial drivers should be on your Mac OSX install disc, I believe they update if necessary (and if it's activated). This should be done while in Windows, not OSX.

You should try going to C:\Documents and Settings\Your user name and delete the following files while LightWave is not open:


If you have any custom menus you may want to rather move these to the desktop instead of deleting them in case that doesn't do the trick. We're getting rid of them to ensure that we're not running into the same problem over and over again.

Try starting LightWave now, if it's still giving you issues press 'd' to go into Options and go to the GL tab. Turn Texture Resolution all the way down, keep Shading Method on "Multitexture", set Geometry Acceleration to "Streaming" and make sure everything below is turned off. Restart Modeler (so the settings are saved) and try to replicate the problem. If it works then try turning these up one by one and see which one seems to break the threshold.

Also, what graphics card are you using? In Windows go to Start > Run and type in "dxdiag" then read the model from the top-left of the "Display" tab. In OSX go to the Apple menu > About This Mac > More Info... and click on the Graphics/Display entry and post the chipset.

03-09-2008, 11:55 PM
Good info Dan, nice to see you active on the boards.


03-10-2008, 12:19 AM
The current version is 10.5.2, and after you load the latest version there is a download for the graphics. I understand that it fixes problems with ATI graphics.

The problem with the Win32/bootcamp is that ATI graphics kind of suck.

03-10-2008, 12:38 PM
its not that the hardware sucks, it just that early driver support was buggy and didn't work all that well, the newest drivers fixes a lot of problems, but I'm sure there are still problems that are not quite addressed yet. Nvidia always seems on top of things when it comes to driver support.

03-10-2008, 09:27 PM
Well... I guess that ATI might've make the best damn graphics are in existence, but well never know because their driver software kind of sucks... mostly a bummer for us.

nVidia rules.