View Full Version : Can't Save "Surface Preset" In 10.5?

02-24-2008, 03:33 PM

I've just installed Lighwtave UB 9.3.1 on my new Mac Pro. Everything seems copacetic, except that I can't save a surface to the Surface Presets--I left-click on the preview icon in the Surface Editor window, select "Save Surface Preset"--and nothing happens.

Please advise.

02-24-2008, 06:15 PM
This is a permissions problem, form here on in you will need to set up a folder system in – User Library<Application Support to work around the problem, call the top folder 'Lightwave3D' and mirror any folders with personal content, i.e.– the full presets library from the main program less the NT supplied content, then when you next open the preset shelf you'll find the drop down menu divided in two parts, the firs being LW content and second user content, this section will be fully edditanble

02-25-2008, 08:44 AM

Thanks, but no luck. The folder hierarchy you describe already exists--Lightwave apparently set it up when I installed the program. "Save Surface Preset" still does nothing. Please advise.

02-25-2008, 09:35 AM
Well have this running just fine on PPC and Intel Mac for 9.3.1, just checked save preset command on the Intel one and it worked, then I deleted it and that worked too.
It's been so long since I installed 9.3.1 that I could not honestly remember whether directory generated itself or I did it but the point is personal presets have to be manually placed here to be editable. Are your Configs set up correctly, is there a folder in User Library< Preferences called 'Lightwabe3D' and is it being written to properly

02-25-2008, 09:50 AM
...a folder in User Library< Preferences called 'Lightwabe3D' and is it being written to properly

Lightwabe? I guess that would be where the Light-toves gyre and gimble (avoiding gimbal lock, of course.)

I've only used the default Configs during my entire career with Lightwave--so I don't really know if they're set up correctly or not. Is there any way to find out?

02-27-2008, 08:35 AM
It gets worse.

I just started a thread about this last night because I lost 6hrs of texture work.
I've tried everything, but I can't find a way to save surfaces. Save all objects doesn't work at all, and you can't save a surface preset shy of saving the actual surface. The problem there is I have a scene that has over 140 surfaces. I don't see the efficiency in saving a new copy of the surface every time I tweak a parameter or change a number.

I'm calling tech support today. I think they have some explaining to do with the UB version cause it's a total failure.

02-27-2008, 09:09 AM
Lets be absolutely clear, the one big change to configs for 9.3 was moving them back out of the Program folder to the User Library Preferences folder, so just as you manually had to place a blank folder in in the Programs folder and name it 'Configs' now you must manually do the same in the User Library and name it 'Lightwave3D', LW will look for it and know what to write to it, you don't need to set up command lines. Go look make sure tou have these set up properly, you should find they contain Extensions 9, Hub 9, Layout 9, License Key, LScript Prefs and Modeler 9 plus any tool configs that write themselves properly. You'll know if their working by the last modified dates assigned to them, just fire up say LW modeler then quit it and their times and dates should appear current.

02-27-2008, 10:25 AM
I did that.

Let's make sure I did it right.

Make new folder called: Lightwave3D. Place it in Users/Library/

Open Modeler. Quit Modeler. Modified dates shows date/time created still. No change. Nothing is written in the folder. What did I do wrong?

02-27-2008, 03:26 PM
Hi hard8,

That full path should be ~/Users/Library/Application Support/LightWave3D/

Now, that's for the Application support stuff as mentioned before.


... is the location of the prefs, and should be auto-generated. Both *should* be auto-generated, for that matter.


02-27-2008, 03:34 PM

I've got the same problem as Hard8. The Presets folder is auto-generated, and is where it should be. But I still can't save presets. Please advise.

02-27-2008, 04:09 PM
Hi Giacomo99 and hard8,

Any chance both of you are using Leopard?


02-27-2008, 04:37 PM
there's a real good chance I'm using Leopard,

02-27-2008, 04:48 PM

I ask because we found a particular bug in file path generation that appears to be specific to Leopard (and appears to work fine in Tiger). That could be causing the problem. I'll post more when we have a definitive answer.


02-27-2008, 05:51 PM
Hi Chilton-

I'm using Leopard too.

04-13-2008, 03:05 AM
Having the same problem.

Any solutions?

I have to save the surface file manually and load it manually via the surface editor (the old way). :(

Double clicking saves so much time.


04-13-2008, 06:44 AM
Caveboy, the problem seems to be with Leopard being fussy about writing to the Applications folder.

Chilton has suggested on the 9.5 Beta forum to move the LW folder from Applications to somewhere else (like to the desktop) but I haven't tried it yet. I don't know enough to say if moving the folder is likely to cause other problems.

05-04-2008, 09:30 AM
Just an addendum to the previous comment-- moving the LW folder to the desktop doesn't do anything either.

It would be REALLY great if someone at NewTek could address this.

05-04-2008, 09:39 AM
This is linked to the Leopard permissions as far as I am aware. Can any Tiger users test this?

05-05-2008, 04:01 PM
Seems to work fine here. I'm on tiger.

05-05-2008, 04:49 PM
Yes it's Leopard related and well documented, Tiger on PPC or Intel does not exhibit any problems at all in this respect