PDA

View Full Version : Texture Problem



We-Co
02-18-2008, 09:34 PM
Hi all, I have a problem with my hand texture on my character. It's grey in certai areas and the rest have color.

Etch
02-18-2008, 09:54 PM
It's likely those polygons weren't selected when you made a surface.

You can fix this by selecting the untextured polys then clicking on the surface button (I think the shortcut is "q") and then select whatever surface you want it to be a part of from the drop down menu. Hit "ok" or whatever the dialog says and your problem should be fixed.

We-Co
02-19-2008, 01:41 PM
I've tried that, but still the same problem.

prospector
02-19-2008, 02:40 PM
Open UV window to that texture, select them on model and find where they are in UV.
Looks as tho they are off the map

We-Co
02-20-2008, 01:55 AM
I tried that also, and sadly nothing. Also the texture shows up fine in Open GL, but when rendered it gets screwed up.

Giacomo99
02-20-2008, 02:45 PM
Maybe you have some extra polys pasted in there?

We-Co
02-20-2008, 05:34 PM
I also looked at that. Plus I redone the texture on the hand and it got even more screwed up.

gerry_g
02-20-2008, 05:56 PM
You definitely got extra geometry, try SHIFT+I

We-Co
02-20-2008, 06:49 PM
It says "No polygons eliminated".

gerry_g
02-21-2008, 03:45 AM
Well there's definitely weirdness in that general area, the texture is all stretched on the back of the hand, there appears to be some sort of non planar poly in there, one thing you could try is lasso selecting in poly selection mode the entire map from the uv window then flip back to the regular viewport and copy and pasting all of the selected poly's into a new layer then checking back to the original layer see if anything was left behind. Other than this would need to see a screen grab of your uv layout to see if there is some irregularity in the layout, i.e. things aren't overlapping, every thing is properly within uv space etc

Sorry I meant cut and paste, brains not working this morning

We-Co
02-21-2008, 05:44 PM
Here is some more screen shots.

When I cut and pasted the only thing left behind were points that I needed.

I have a UV Texture for the hands, and a different one for the arms. Is that going to be a problem? Also the points that are select in the picture below is where the texture is messed up (Plus there not connected to anything).

gerry_g
02-21-2008, 06:44 PM
Maybe you have two edge rows or points on top of one another in the uv mesh, try going through them in the affected area one at a time on the uv side while verifying that the mesh in the normal viewport is showing the same results ( i.e. if you select one point on the uv mesh but two get selected on the real one you'll know where you're problem is). Other than that you could try any of the following
One_ try unwelding and then rewelding the uv's see if the points get re assigned, some times happens with stray verts, and try the same again with the full mesh in the normal window see if anything happens.
Two_hit the backslash key see if there's any hidden geometry
Three_ in Polygon Statistics check for one point polys and delete them.
Four_ lasso select the entire uv map in poly mode and hit q to bring up the surface name requester and reapply the name for the map.

We-Co
02-21-2008, 08:36 PM
Yeah, it's the first one. I have point "Arm" UV's inside the "Hand" UV's. It's a total mess and I'm going to try and redo the UV's and see if that helps.

We-Co
02-22-2008, 12:23 AM
Hmmmm... I redid the textures, and it worked when I just did the hands. Then I did the arm textures and it got screwed up again, but only in one spot. Also when I do eventually get this problem fixed, how exactly do I get rid of the headiest seam?

We-Co
02-22-2008, 01:11 AM
Okay, I had to Unweld, and Merge. But how do I get rid of the seams in the texures?

gerry_g
02-22-2008, 03:54 AM
You are talking about a texture seam right not say a two point poly seam or the two meshes are unjoined, cos the mapping route you have chosen, i.e. of having separaet arm and hand maps will lead to seam problems, you will learn from experience to put seams where they are least noticable, or get yourself a 3D paint program like Maxons BodyPaint 3 or Modo or even Hexagon that will allow you to paint over seams to disguise them to some degree, also Photoshop CS3 allows you to import a mesh and texture for manipulation but whether it will allow you to blend two textures I'm not sure. The best option thats free I can offer is to merge both maps and stitch the arms back on to the wrists but taper/shrink the arms along their length as they move away from the hand so as to allow you to have maximum texture size for the hands where you need it and less for arms where you don't.

We-Co
02-22-2008, 07:36 PM
Thanks Gerry.