PDA

View Full Version : Visible seams between polygons



IgnusFast
02-12-2008, 07:23 AM
I'm having an odd problem with the Lightwave rendering engine leaving visible seams between polys. I've attached an image which illustrates it, along with little wireframe clips. All the vertices are shared, and the there's not much to the affected surfaces.

This is Lightwave 9.3.1, running on Vista 64. It doesn't matter if Radiosity is enabled or not.

Any suggestions?

IgnusFast
02-12-2008, 07:36 AM
Can't edit. Stupid forum.

I think I figured out what is happening, but not why. I was using FPrime to do almost all of my rendering, and noticed some time ago that FPrime has a lot of trouble with odd smoothing/reflection values and having shadows render through the back of some surfaces. So almost all of my surfaces are beveled flat (for the angle issue) and set to double-sided (for the shadow issue).

Turns out that the double-sided surfaces are the ones showing seams between polys, even though that doesn't happen in FPrime. Not sure why it would happen in the native engine; you don't see seams showing whatever is behind the polys when they're not double-sided, and it's not like double-sided polys have edges...

Any ideas?

Giacomo99
02-12-2008, 08:31 AM
You forgot to attach the image.

There can be all sorts of reasons why this can happen--the most common one for me is a double-sided surface with a flipped polygon.

IgnusFast
02-12-2008, 09:47 AM
Balls, I'm just having all kinds of trouble with the forum today! I uploaded the image, but for some reason it didn't make it into the post. I'll have to re-upload it later, when I get home from work.

It is definitely the double-sided surfaces that cause the problem with the native renderer, but I checked *all* the normals, and there are no flipped polygons at all. I removed double-sided from every surface on the ship (it's a space station in this case) and everything rendered fine. Except in FPrime, of course, where I suddenly have all kinds of shadow issues again. :)

Stooch
02-12-2008, 02:55 PM
never use double sided polys to cover up bad mesh modeling. Hit w and make sure there are no polygons with 2 points. if there are, hit the + button next to them and then delete.

you also want to run the unify tool in the reduce tab. sometimes 2 polygons can occupy the same point space.

IgnusFast
02-12-2008, 06:48 PM
never use double sided polys to cover up bad mesh modeling. Hit w and make sure there are no polygons with 2 points. if there are, hit the + button next to them and then delete.

Wow, how can I possibly not take that personally? I said that I believe it to be a bug in FPrime, since the native renderer does NOT evidence the shadow/light leak issues I was experiencing. But since you appear to be the master of all meshes, I'd welcome it if you'd take a look at this test scene and tell me what I've done wrong. Images illustrating the issues are included in the archive.

Here's the image I failed to attach earlier.

Stooch
02-12-2008, 06:55 PM
Wow, how can I possibly not take that personally? I said that I believe it to be a bug in FPrime, since the native renderer does NOT evidence the shadow/light leak issues I was experiencing. But since you appear to be the master of all meshes, I'd welcome it if you'd take a look at this test scene and tell me what I've done wrong. Images illustrating the issues are included in the archive.

Here's the image I failed to attach earlier.

i dont care if you take it personally. I tried to help you with my post and if you... [MODERATOR deleted insult]

IgnusFast
02-12-2008, 07:00 PM
Okay, thanks for playing. Anyone else?

Surrealist.
02-12-2008, 08:31 PM
Sorry I don't have Fprime. Is there anything else to look at in the native renderer? Or is that sorted out?

IgnusFast
02-12-2008, 08:36 PM
No, I think I understand what I did wrong with regard to the native renderer - I admit that I abused the double-sided polys. Just frustrating that I can't get Worley to respond with regard to the FPrime issues.

Thanks for offering help!

Surrealist.
02-12-2008, 09:54 PM
No problem. Good luck with the fprime fix.

kopperdrake
02-15-2008, 11:46 AM
Can you send a link to the object and scene and I'll have a look if you like?

cagey5
02-15-2008, 12:09 PM
It's attached below the picture showing the problem Kopperdrake.

Giacomo99
02-15-2008, 03:12 PM
Basic answer: FPrime is quirky. I encountered similar problems during my brief time using it. (I had to stop using FPrime because of conflicts with my video card, detailed elsewhere on this forum.)

Part of the problem might be that you're just interrupting the render too early, effectively imposing a very low anti-aliasing setting on the render. If you let FPrime keep iterating for awhile, the artifacts might disappear on their own eventually. (I found this to be a fairly annoying aspect of FPrime--although it creates an in-the-ballpark render very quickly, it wasn't really much faster than the native LW renderer when anti-aliasing was taken into account.)

The other thing--and again, this is a particular quirk of FPrime--is that it often creates those kind of artifacts when the angle of the light is at a close angle to the plane of the surface. If there's a some kind of noisy texture on the surfaces, though, it's usually less noticeable.

Someone more knowledgeable than I about FPrime might be able to solve these problems, but my advice is to just render the project with the LW native renderer.