PDA

View Full Version : [Animation] Rotation between keyframes is strange



Anchelito
01-25-2008, 07:35 AM
hello there. i have a problem that really drives me crazy.
i do have a bone and all i want to do is to rotate it on a single axis.
so i have a key-frame at key 0 with the standard-position then i go to keyframe 10, rotate the bone on the axis and create that keyframe. looks good until now. but when i look at the animation between the two keyframes i set i see that lightwave doesn't only rotate on the one axis but also on a second one so that the animation somehow looks like an arc instead of a straight line.

why is lightwave doing this strange thing???? it is the simplest animation i could imagine and lightwave just can't seem to do it.

hope you can help me! thanks a lot!

greetings

K-Dawg
01-25-2008, 08:10 AM
It depends on if you are "Bending" an object. I just did something simple the other day like closing an open Flyer. I used Weightmaps for the left and right side and assinged them to the Bones. That way the Jaggies and so while rotating the bone are away and the Flyer shuts like I wanted it to.

Maybe thats a help for you.

Greetz

Anchelito
01-25-2008, 08:23 AM
wow .. that sounds complicated for such a simple task. i can't imagine that i am the only one having the problem. why can't i just rotate the bone the way i want? why doesn't the animation rotate the bone the way i rotate it in the view?

there has to be another explanation.

anyway ... thanks a lot for your answer!

greetings

K-Dawg
01-25-2008, 08:28 AM
I dont understand what you mean. Actually it does what you want. I use the Weightmaps so it doesn't deform the other sinde of the flyer. On something else I used 2 Bones to open a window. Left and right side opens in the middle. No weightmaps or what ever and it worked just fine. For the flyer I used the Weightmaps like I said, so it doesn't deform the other side of the flyer cause that is one simple box with 2 segments.

Greetz

Castius
01-25-2008, 10:09 AM
Euler rotation is based of it's parent coordinate space. Watch the video on gimble lock.

When you are directly controlling any item on a rig you should create a "null bone" (a small bones) or null as the parent. The child object is the one you are controlling and is called an offset. This child object should have there rotation at 0,0,0. This way you can eliminate a large % of gimble lock. If you have a really complicated setup that has to rotate on two axises alot you may even need to create two offsets. This way you are only controlling rotation on one axis per object.

Surrealist.
01-25-2008, 03:13 PM
hello there. i have a problem that really drives me crazy.
i do have a bone and all i want to do is to rotate it on a single axis.
so i have a key-frame at key 0 with the standard-position then i go to keyframe 10, rotate the bone on the axis and create that keyframe. looks good until now. but when i look at the animation between the two keyframes i set i see that lightwave doesn't only rotate on the one axis but also on a second one so that the animation somehow looks like an arc instead of a straight line.

why is lightwave doing this strange thing???? it is the simplest animation i could imagine and lightwave just can't seem to do it.

hope you can help me! thanks a lot!

greetings


OK, there are several things to look at with regards to animating with keyframes in LightWave or any other package for that matter.

Animating with keyframes is set up so you have the most amount of control of your animation at various levels. At the default, LightWave assumes you want the most free rotations and movement possible. A more-or-less free-form approach.

If you want to restrict movement on on axis there are two simple solutions:

1) click on the actual handle - the colored circle you get when in Rotate mode - so that the item rotates only on that axis only.

2) Lock off the rotations you don't want using the HPB squares at the bottom left of the screen beside the numeric inputs. Highlighted squares are active.

This is useful when setting up rigs so that certain bones such as a knee joint only rotate in one direction and yo don't accidentally rotate on the heading or pitch and mess up a pose.

Getting deeper into rotations, movements and keyframes you will notice the choices you have for what is actually recorded when you create a keyframe.

Hit Enter and look at the Create Motion Key requester.


You will see you not only have a choice as to which items get a keyrframe but also to which channels get the keyrame. This is very important the more complex your animation becomes. And for this reason many people prefer to use the Auto Key Create feature.

If you press o for options, in the General tab, you will see "Auto Key Create" and some options there. Off, Modified Channels and All Motion Channels. Set to Modified Channels - the preference in most cases - this will set a key frame only on the rotation, movement or scale you have specified as son as you make the change.

And now that you are animating away you'll find that there is extra movement. This is because you have been creating curves. So you need to know how to manage curves.

Take a look at the end of this thread (http://www.newtek.com/forums/showthread.php?t=79077) where I explain it a little more.

Then finally you have the possibility of gimbal lock which is another story. It is solved as described above.

Anchelito
01-26-2008, 05:20 AM
hey ... thanks a lot for the answers ... i managed to get rid of the problems with the help of a youtube-lightwave-tutorial. i had to somehow reset the orientation of the pivot of the bones via shift-p.



1) click on the actual handle - the colored circle you get when in Rotate mode - so that the item rotates only on that axis only.


i exactly did that! the problem is really strange. the keyframes i set where okay, but the inbetween was completely strange.

well, but that's history now.

thanks a lot!

Surrealist.
01-26-2008, 05:38 AM
Good, just good to make sure everything that is obvious is eliminated . Glad you figured it out.

Castius
01-28-2008, 02:21 AM
shift-p is record pivot rotation. This works but is a quick fix. But this is something you want to avoid as much as possible. As LW has many areas that fail to consider edited pivots properly. Creating a null bone like i described in my previous post is the proper method for created a bones to animate. It is a extremely important process to understand if you want to create simple reliable rigs in any program. Changing the pivot only leaves room for potential problem down the road

It's a simple rule, if you want to animate a item in a rig. You create a child item weather it be a bone or a null. Then you set the child Rotation to 0,0,0. This way you can reset any part of your character by setting all your controllers to 0,0,0. As well as reducing the chances of gimbal lock.