PDA

View Full Version : Layout showing duplicate cameras



kopperdrake
01-18-2008, 07:03 AM
Okay, this is weird but as it's the second time in 3 days I've had it I thought it was time to ask if anyone else is having this problem.

I've a large scene, around 1,300 objects, also uses HD Instance heavily. It's a master scene, and I'm cutting things out for a lower-density version for a localised render of an area of it. There are three cameras.

Once I've cut out everything I don't need (making sure there are no nulls referencing objects via HD Instance left in the scene which is guaranteed to crash my machine when I reload the scene) and reloaded it I'm getting duplicate versions of each of the cameras. I can't choose them and move them, if I try to move one it will move another camera, there is more than one camera highlighted as 'chosen' in the drop down list you can see, though I'm not holding shift down. If I choose one camera and try to look through it I can't see anything in the open GL window. If I try and render a frame I'm getting a *very* slow radiosity solution starting but unless you have a spare year it's not going to render.

Running Win XP Pro on an 8-core Mac, latest build of LW.

Any pointers? I've looked at the scene file in Notepad and it's adding a second set of camera data for some reason when saved out, weird!

I've cut those out of the text file manually and the cameras now work, but also just discovered it's adding a second set of lights too - all of them duplicated!

By hacking and slashing the scene file I can get the scene working without having to redelete all the excess objects from the original master scene but why is this happening?