PDA

View Full Version : IK and IKboost question-URGENT



medicalart
01-15-2008, 10:46 AM
I"ve got a tube with spheres parented to it. (They are on separate layers of the same object.) The tube deforms with IKboost, but the spheres are left behind and are not deformed. It's as if they're no longer parented. If I simply move the parent, then the child objects follow. But they don't deform.

Bones are on. Enable deform is on . Enable IK is on. IKboost is on. Skelegons were drawn in Modeler and then converted in Layout.
Am I doing something wrong, or doesn't IK work in this situation? Thanks.

adamredwoods
01-15-2008, 11:16 AM
Still working on your RNA?

Offhand, I might suggest selecting your spheres and activating the "Use Bones From" setting. (Select Object hit P then hit Shft-B)

medicalart
01-15-2008, 12:38 PM
AdamRW, you've saved me again! Yes, I'm still working on the DNA. I've made no progress--still setting things up. Baffled as to why parented items aren't included in the deformation. Wondering if there's a preference/option to avoid having to use "use bones from". Anyway, thanks for input.

adamredwoods
01-15-2008, 02:52 PM
You can also do it once, open up CommandHistroy, copy the "BoneSource" command with the number after it, then select a new object and execute a CommandInput and paste the command in. Would be quicker if you had over 20 of these to do.

Castius
01-15-2008, 04:08 PM
Medicalart select the sphere object and go to the deform tab. And apply a FX_HardLink. This will attach your sphere to the closest polygon of your tube.


Parenting an object to a deforming object is not enough to make it fallow it, when the mesh is being deformed.

medicalart
01-15-2008, 07:00 PM
Thanks, will give both a try.

Dodgy
01-15-2008, 09:10 PM
You'll need to add ClothFX to your tube and File>Scan it before the Hardlink will work though.

medicalart
01-15-2008, 09:15 PM
Thanks Dodgy. I was wondering why I couldn't get it to work.

Castius
01-16-2008, 12:31 AM
Thanks Dodgy, I completely forgot about that step. It's been to long since i used LW. Sorry for the missing information medicalart

medicalart
01-16-2008, 07:54 AM
I'm wondering why IKbooster button (on the menu) doesn't simply activate the selected object by default. Or have a submenu with a list of objects to choose from..