PDA

View Full Version : How to delete particles?



serge
01-13-2008, 07:25 AM
I have a particle emitter. I want to delete specific particles from the emitter. I go to the editFX tab, activate the edittool, choose the ID-number of the particle and click delete. This works. However, when I save the scene and reload it again the particles I deleted are back. Did I miss something? BTW, when I delete a particle, it gets physically deleted, but the emitter still says it has the original amount of particles.

walfridson
01-13-2008, 08:35 AM
Same here. Resaved the .pfx but no.

serge
01-13-2008, 08:56 AM
Thanks Walfridson. I just checked LW8 and the same thing happens there. I'll wait a bit to see if somebody has a solution, and if not I'll report it as a bug.

serge
01-13-2008, 09:14 AM
BTW, same goes for moving particles. Reload the scene and the particle is back at it's place.

evenflcw
01-13-2008, 10:32 AM
Works here in 8.5. Moved/Deleted particle, saved pfx, saved scene;cleared scene; reloaded scene; fx edits still present.

Mind you delete doesn't remove the particle completely (even if you have EditFX set to affect all frames. BAD!). Instead it kills the particle on the frame your currently on (atleast for me). So if you issued the delete command on frame 20 it would still be there on frames 0-19. So if you deleted the particle on the last frame you would't see much of a difference. Maybe if you used fixed frames it would act differently...?

serge
01-13-2008, 02:06 PM
evenflcw, thanks for the reply. Yes, when I save the pfx all edits are present. But what I actually meant was keeping the edits without saving a pfx.

Lets say I created a scene with particle movement. I'm editing the path of some particles and delete a few, and then decide to continue some other time. When I save and reload the scene all my edits are gone (I don't want to save a pfx because then I can't change the parameters anymore).

Or, let's say I create an object from which I want particles to generate from it's vertices. I decide that some vertices don't need particles so I delete them. Then I decide to save the scene and continue another time. On reload those particles are back again. (Again, I don't want to save a pfx at this moment.)

I was wondering if this is a limitation or whether it's a bug.

Sensei
01-13-2008, 07:16 PM
I was wondering if this is a limitation or whether it's a bug.

Neither. Particles are dynamically created unless you have pfx.. LW doesn't know about your deletion because you didn't save it, so next time you work on generated particles from scratch again..

serge
01-14-2008, 04:56 AM
Neither. Particles are dynamically created unless you have pfx.. LW doesn't know about your deletion because you didn't save it, so next time you work on generated particles from scratch again..
That makes sense. Thanks Sensei.