View Full Version : Cloth & MDD issues in 9.3.1

01-11-2008, 04:45 AM
Hi! I have an animation that is really causing me some problems. First of all, I originally did all of this in 9.2 and it works fine. No problems. But the person I am building it for uses 9.3.1 (can't change) and that has caused some major problems. Here is the steps I have done:

1. animate a walk cycle for the object with shift spline transform
2. Scan the motion of each layer (1, 3, 4, 5, 6 & 7) that is animated with the cloth plugin to build an mdd file. (subdivision set to "Last")
3. remove cloth from each layer and apply MD Plug, importing the mdd file for each layer. Remove any keyframes and all the shift spline transform objects.
4. apply nodal displacement to layer 1 that has been baked. (subdivision order set to "After Bones". Nodal Displacement and Shift Spline Tranform won't work at the same time for some reason because they require different subdivision order settings)
5. apply cloth to layer 1 and scan its motion again saving the mdd as a different name.
6. parent layer 8 (has not been baked) to layer 1. Apply FX_Hardlink so that layer 8 inherits the movement and displacement from layer 1's mdd file.

Again, this all works fine in 9.2 as you can see in the first image. In 9.3.1 everything works ok until you close the scene and re-open it. Then you get what you see in the second image.

BTW...I have tried rescanning everything in 9.3.1 and seeing if that fixed it but it doesn't. It has the same problems.

Can anyone help me out with a solution?


01-11-2008, 05:25 AM
I would make sure its not an opengl issue. Ive had similar thing happen in 9.3 with mdd files. I also make sure that the subdivision order between scanning and applying the mdd files are the same. I also have been using the mdd point node thats part of the DPKit to be able to control the playback speed of the mdd files using an envelope. BTW shift spline transform seems to override all other displacements. You can apply additional displacements to mdd files if you use the mdd pointer in the DPKit.