View Full Version : having trouble rendering - memory leak?

01-09-2008, 07:52 AM
I have a scene that I've been having trouble rendering. When I hit F10 to render it, things start out fine but eventually the rendering slows way down. I started it around 3 or 4 pm on Monday and when I came back this morning, it was working on frame 76 and the last frame had taken over two hours to render. I hit 'Abort', moved the time slider to frame 75 and hit F9. The frame rendered in less than 50 seconds.

I used fertilizer to animate it (using LW 9.3 CFM on the mac). I was having trouble with it rendering there so I decided to try it in the UB version. I baked the motion into an .mdd file (applied softFX with operators turned off, then hit 'Calculate') and loaded it up in LW 9.3.1 UB with MD Plug (had to alter the scene file with a text editor to fix path problems to get it to reload properly).

The attached file is the scene with the .mdd file. It uses no external plug-ins.

I haven't tried to render it on a Windows machine so I don't know if it has the same problem on one of those.


01-09-2008, 09:28 AM
Not sure anything I add will be a 'solution' as such, but I'm more than happy to tell you what I have heard from other folk - and one of my own strange experiences........

My experience: Only happened in one job I did, where I had an object increasing in Y-scale, so it grew from under the floor to reach its full height. When the render hit the frame where it started to grow, the render went from 1.5 minutes a frame to just under two hours a frame. This was a final gather render without any plugins for objects or scene.
I can only guess that it baulked when planes were occupying the same space, or something else to do with final gather calculations applied to zero-scaled [in one direction] objects.

Other people: Have reported that having 'render lines' checked can slow renders down a lot in some circumstances, though I'd have thought that would apply to the whole sequence, not just particular frames.

I'll have a gander at your scene to see if I can find any weirdness.

Hope you get it sorted.


01-09-2008, 05:51 PM
I did some more testing on this and still haven't figured it out. The amount of memory used (as shown in the System Monitor Software) doesn't go up during the render. I rendered frames 81-83 and the render times increased each frame with frame 83 being noticeably longer than frame 81. Then I rendered frames 83-86. Frame 83 rendered fairly quickly but by frame 86 the render time was longer again.

I tried rendering without AS and higher AA settings. That didn't help. I raised the segment memory limit and that helped for a frame or two but didn't fix the problem.

01-09-2008, 06:32 PM
I have to apologise - I haven't had time to check the scene file yet. Let's just say I have had 'client issues'! (Research and prep for a presention).

I do remember an issue mentioned in LW where, with certain settings of cached radiosity, the render time would increase almost twice over two frames, and again twofold for every frame rendered thereafter.

As I mentioned, I've not had time to check the file so I don't know if radiosity is even a part of your scene, but I will make sure I find some time the morro to have a look - I am running all Windows machines.

I'll be sure to let you know what I see.


01-09-2008, 08:51 PM
no worries. It's not a commercial project and I have a Windows machine I can try it on.

I have radiosity turned on tho I may have experimented with it at some point.

01-09-2008, 10:14 PM
I have the same problem with the scene in Windows XP.

The problem (decreasing render times) happens with AA set to 1, and with AS, MB and DOF turned off. It just takes a few frames longer before it starts to slow down

I did a render starting at frame 87.
frames 87-91 were 11 seconds or less.
frame 92 took 12 seconds to render
93 took 31.4
94 took 50.2 seconds
95 took 78 seconds
96 took 103.8 seconds

I then stopped the render and started it at frame 96 which then took 13 seconds to finish rendering it. It's the same frame that took 103.8 seconds less than a minute earlier.

The problem doesn't seem as bad with the Classic camera. Of course, the classic camera doesn't support photoreal DOF or MB and the initial render speed is slower. I did a render of frames 87 thru 96. 87 rendered in 77.6 seconds and 96 rendered in 101 seconds. then I rendered starting with 96 and then 96 rendered in 88 seconds. The time is still increasing but not quite as sharply.

If I knew Lscript I could possibly hobble together a script that'd do a preview render, advance to the next frame, then do a preview render. The images could be saved via an image buffer saver.