PDA

View Full Version : Perspective view "stuck"



Steamthrower
12-15-2007, 08:15 AM
While modeling this morning my mouse did a quirky ninja move of its own. I was rotating the perspective view (in Modeler) and I found myself with it stuck looking straight down. Now, whatever I do, I find the perspective view looking straight down. I can't get the view to rotate on anything else but the Y axis.

Even if I load a new model my perspective view is stuck on this axis. Is there anything I can do to "refresh" the viewport's position without deleting my config files...I hate doing that since I have everything customised to my likings...

Sensei
12-15-2007, 08:16 AM
Switch perspective to f.e. top view, and then back to perspective.. I am having it too in every LW version..

IMI
12-15-2007, 08:28 AM
Inigo, you can also hold down the ALT key (or whatever the Mac equivalent is) and use your left mouse button to get out of that. Just another way to rotate the "camera" in perspective in Modeler.

evenflcw
12-15-2007, 08:30 AM
Stop using the viewport buttons. Start using the shortcuts instead and you'll never get stuck. Alt+LMB click and drag in the viewport to get unstuck, and keep using that combo!

EDIT: What he said!

Mark The Great
12-15-2007, 10:28 AM
I've been having a problem (as of yesterday) with the perspective view. I'll be rotating around an object and it suddenly starts spinning about 50 times faster than it should.

Steamthrower
12-15-2007, 01:54 PM
@ Sensei: tried that, and it didn't work. I even tried switching to side and UV texture views in the vain assumption that it would do something.

@ IMI: thanks for the tip! This worked and got my view out of the rut.

@ evenflcw: stop using the viewport buttons? Are you kidding? That's what I love about LW, those buttons. Probably a deciding factor in making me open up my wallet in the first place. :D

@ Mark the Great: that's happened to me before too. Bad thing is I can't replicate it when I want to.

Ztreem
12-15-2007, 04:38 PM
I've been having a problem (as of yesterday) with the perspective view. I'll be rotating around an object and it suddenly starts spinning about 50 times faster than it should.

Go to the display option (press the 'd' key) and set the input device to mouse, it's probably in tablet mode.

IMI
12-15-2007, 05:37 PM
@ IMI: thanks for the tip! This worked and got my view out of the rut.




No problem. That one gets me from time to time too. Seriously annoying, isn't it? :D

cresshead
12-15-2007, 06:16 PM
it's called gimbal lock btw...and yeah the alt key is your friend when this pops up.

Andyjaggy
12-15-2007, 07:03 PM
As said above just switch to using the alt+lmb to rotate in the perspective view. It will be a bit weird at first but once you get used to it it is much much faster.

IMI
12-15-2007, 07:59 PM
As said above just switch to using the alt+lmb to rotate in the perspective view. It will be a bit weird at first but once you get used to it it is much much faster.


Yeah, good advice. And if you start using modo you'll be glad you're in the habit of doing that, because the rotation tool at the top of the viewport is completely backwards from Modeler.

Now I'm thinking it'd be nice if SHIFT+LMB would pan the camera in Modeler.

Steamthrower
12-15-2007, 08:17 PM
Yes, very nice idea. On a Mac that would best work out to Cmd+LMB.

Not using keyboard shortcuts as often as I should really slows my speed sometimes. I need to get used to it I guess - it's what kills me when fiddling in Blender.

Thanks all, for the tips. And now I know the official term: gimbal lock. :D

IMI
12-15-2007, 08:48 PM
Here's another tip: When they tell you you should set your keyboard shortcuts to Default, like in some video tutorials, you ought to listen to them. ;)
A few years ago I began creating all my own custom shortcuts, which *I* know and have memorized, but it got to the point where I entirely forgot what tabs some of the tools were under, and had assigned their shortcut keys to other things. *Really* screwed me up.

I still use my own keys, but have them saved in a keys .cfg file, so I can go to Default when I need to, and get my own back when I'm done with whatever tutorial I was working on.

BTW, gimbal lock is also what happens in Layout when a bone gets locked into two axes sharing the same one, causing a loss of being able to control one of the three axes. LW 9 has a new tool for defeating that, called "Quattro".

IMI
12-15-2007, 08:56 PM
BTW, Roger, I am in need of a nice shrubbery. ;)

Snosrap
12-15-2007, 09:13 PM
Now I'm thinking it'd be nice if SHIFT+LMB would pan the camera in Modeler.

Alt + shift and LMB pans. BTW, Alt + Crtl and LMB zooms. I only use those viewport buttons when I'm stuffing my face with my other hand. :D

Cheers
Snosrap

IMI
12-15-2007, 09:16 PM
Alt + shift and LMB pans. BTW, Alt + Crtl and LMB zooms. I only use those viewport buttons when I'm stuffing my face with my other hand. :D

Cheers
Snosrap

Oh cool, thanks! :)
I didn't know that.

Hopper
12-15-2007, 10:06 PM
IMI, check out your mouse drivers if you have anything that will let you reassign mouse keys (without having to reassign in the program itself).

I rarely have to use any strange key combos while doing basic modeling (except numeric input obviously). 5 button mouse + combos with Alt, Shift, Ctl, Alt/Shift, Ctl/Shift, etc... You can get a LOT of basic functions done by just utilizing your mouse.

The trick for me was to simply add one at a time, slowly. After a while, you don't even have to think about it. I have Move, Size, Stretch, Extrude, Extender Plus, Bevel, etc... all programmed to mouse combos. Makes for ultra fast work.

Mark The Great
12-15-2007, 10:32 PM
Go to the display option (press the 'd' key) and set the input device to mouse, it's probably in tablet mode.

Hmmm... Nope, it's in mouse mode.

Ztreem
12-16-2007, 04:56 AM
Strange, then I don't know, maybe a driver issue?

Sensei
12-16-2007, 05:03 AM
@ Sensei: tried that, and it didn't work. I even tried switching to side and UV texture views in the vain assumption that it would do something.


I told you wrong, because had no issue for a quite a while (only because I know about it and trying to not go so extreme rotations). I should tell you "switch view to none, then back to perspective".. But IMI idea is probably much faster.. :)

archijam
12-16-2007, 05:52 AM
I have the same problem when opening XP LW in Parallels. In my case, tablet mode is the only way to get the mouse to act sensibly ..

j.

IMI
12-16-2007, 06:30 AM
IMI, check out your mouse drivers if you have anything that will let you reassign mouse keys (without having to reassign in the program itself).

I rarely have to use any strange key combos while doing basic modeling (except numeric input obviously). 5 button mouse + combos with Alt, Shift, Ctl, Alt/Shift, Ctl/Shift, etc... You can get a LOT of basic functions done by just utilizing your mouse.

The trick for me was to simply add one at a time, slowly. After a while, you don't even have to think about it. I have Move, Size, Stretch, Extrude, Extender Plus, Bevel, etc... all programmed to mouse combos. Makes for ultra fast work.

I'm using the Logitech MX Revolution Laser mouse most of the time with Modeler. It has 5 buttons plus two wheels, and can be reprogrammed, but I don't think on a per-program basis. It's all or nothing, and I have it set mostly for web stuff like zooming in, scrolling and so on.
But I bought this Logitech gaming keyboard with 18 extra keys over three modes, for 48 extra keys, all of which can be reprogrammed to do whatever, including key combinations. For example, in the 2nd mode, I press the G7 key to open Modeler, and the G8 key to open Layout. And I have my third mode for just Modeler key assignments. It's pretty cool, really. :)

Orimar
12-16-2007, 11:25 AM
BTW, there is another way to get out of the "Gimbal Lock" situation in the perpective view (in Modeler) and bring the object back to its original position on all axes. Select an empty layer and press "a" (View > Viewports > Fit All) and, of course, go back to the layer your object is in. It should be sitting up nice and straight, waiting for you.

.O.